# CVE-2018-8097: Eve allows execution of arbitrary code

> Remote attackers can execute arbitrary code via the where parameter in the Eve Python framework.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8jxq-75rw-fhj9, PYSEC-2018-8

## What is CVE-2018-8097?

CVE-2018-8097 is a critical code injection vulnerability in n/a, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

io/mongo/parser.py in Eve (aka pyeve) before 0.7.5 allows remote attackers to execute arbitrary code via Code Injection in the where parameter.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2018-8097?

3 open source packages ship an affected version, including eve. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eve` | PyPI | All versions | 0.7.5 |
| `eve` | PyPI | All versions | 0.7.5 |
| `eve` | PyPI | All versions | 0.7.5 |

Products: Python-Eve Eve.

## How do I fix CVE-2018-8097?

Upgrade eve to 0.7.5 or later.

## Is CVE-2018-8097 being exploited?

There is no known exploitation of CVE-2018-8097 in the wild and no public exploit code.

Public exploit code:

- CVE-2018-8097 PoC (github_poc): https://github.com/SilentVoid13/CVE-2018-8097
- POC for CVE-2018-8097 This script exploits CVE-2018-8097 and can retrieve files and contents using a blind RCE method. (github_poc): https://github.com/StellarDriftLabs/CVE-2018-8097-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8097 and fix it if it is affected.

What it is: CVE-2018-8097 is a critical code injection vulnerability in n/a, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8097 in the wild and no public exploit code.

Affected packages and fixed versions:
- eve (PyPI): affected all versions; fixed in 0.7.5
- eve (PyPI): affected all versions; fixed in 0.7.5
- eve (PyPI): affected all versions; fixed in 0.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8097/ (Markdown: https://insights.sbomify.com/CVE-2018-8097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8097
- OSV: https://osv.dev/vulnerability/CVE-2018-8097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8097/
Summaries are generated and may contain mistakes; the official description above is the record.
