{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:mailer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-8718 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:mailer to 1.21 or later.","what":"CVE-2018-8718 is a high-severity vulnerability in n/a, published on 27 Mar 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-8718 and fix it if it is affected.\n\nWhat it is: CVE-2018-8718 is a high-severity vulnerability in n/a, published on 27 Mar 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-8718 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.21\n- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-8718/ (Markdown: https://insights.sbomify.com/CVE-2018-8718/index.md)","id":"CVE-2018-8718","markdown":"https://insights.sbomify.com/CVE-2018-8718/index.md","name":"CVE-2018-8718","record":{"aliases":["GHSA-6g57-h38c-q52g"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Mailer Plugin","requires_auth":"low_privilege","summary":"Authenticated attackers can exploit CSRF in the Jenkins Mailer Plugin to send unauthorized emails as arbitrary users.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mailer","vendor":"jenkins"}],"cvss":{"score":8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-site request forgery (CSRF) vulnerability in the Mailer Plugin 1.20 for Jenkins 2.111 allows remote authenticated users to send unauthorized mail as an arbitrary user via a /descriptorByName/hudson.tasks.Mailer/sendTestMail request.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2018-06-05","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-06-10T15:16:41Z","kind":"github_poc","ref":"https://github.com/GeunSam2/CVE-2018-8718","stars":1,"title":"POC of CVE-2018-8718 + tool"},{"date":"2018-06-05","kind":"exploitdb","ref":"44843","stars":null,"title":"Jenkins Mailer Plugin \u003c 1.20 - Cross-Site Request Forgery (Send Email)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cross-Site Request Forgery in Jenkins Mailer Plugin","id":"CVE-2018-8718","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"Information disclosure in n/a","id":"CVE-2018-8719"},"packages":[{"ecosystem":"Maven","fixed":["1.21"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:mailer","purl":null,"source":"GHSA-6g57-h38c-q52g"},{"ecosystem":"Maven","fixed":["1.21"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:mailer","purl":"pkg:maven/org.jenkins-ci.plugins/mailer","source":"GHSA-6g57-h38c-q52g"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2018-8717"},"products":["n/a"],"published":"2018-03-27","related":[{"cvss_score":4.8,"headline":"Improper Validation of Certificate with Host Mismatch in Jenkins Mailer Plugin","id":"CVE-2020-2252","kev_date_added":null,"published":"2020-09-16"},{"cvss_score":4.3,"headline":"Cross-Site Request Forgery in Jenkins Mailer Plugin","id":"CVE-2022-20613","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":4.3,"headline":"Incorrect Permission Assignment for Critical Resource in Jenkins Mailer Plugin","id":"CVE-2022-20614","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":3.7,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Jenkins-mailer-plugin","id":"CVE-2017-2651","kev_date_added":null,"published":"2018-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated attackers can exploit CSRF in the Jenkins Mailer Plugin to send unauthorized emails as arbitrary users.","url":"https://insights.sbomify.com/CVE-2018-8718/"}