# CVE-2018-8718: Cross-Site Request Forgery in Jenkins Mailer Plugin

> Authenticated attackers can exploit CSRF in the Jenkins Mailer Plugin to send unauthorized emails as arbitrary users.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6g57-h38c-q52g

## What is CVE-2018-8718?

CVE-2018-8718 is a high-severity vulnerability in n/a, published on 27 Mar 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site request forgery (CSRF) vulnerability in the Mailer Plugin 1.20 for Jenkins 2.111 allows remote authenticated users to send unauthorized mail as an arbitrary user via a /descriptorByName/hudson.tasks.Mailer/sendTestMail request.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-8718?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:mailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:mailer` | Maven | All versions | 1.21 |
| `org.jenkins-ci.plugins:mailer` | Maven | All versions | 1.21 |

Products: Jenkins Mailer.

## How do I fix CVE-2018-8718?

Upgrade org.jenkins-ci.plugins:mailer to 1.21 or later.

## Is CVE-2018-8718 being exploited?

There is no known exploitation of CVE-2018-8718 in the wild and no public exploit code.

Public exploit code:

- POC of CVE-2018-8718 + tool (github_poc): https://github.com/GeunSam2/CVE-2018-8718
- Jenkins Mailer Plugin < 1.20 - Cross-Site Request Forgery (Send Email) (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2020-2252](https://insights.sbomify.com/CVE-2020-2252/): Improper Validation of Certificate with Host Mismatch in Jenkins Mailer Plugin (medium 4.8)
- [CVE-2022-20613](https://insights.sbomify.com/CVE-2022-20613/): Cross-Site Request Forgery in Jenkins Mailer Plugin (medium 4.3)
- [CVE-2022-20614](https://insights.sbomify.com/CVE-2022-20614/): Incorrect Permission Assignment for Critical Resource in Jenkins Mailer Plugin (medium 4.3)
- [CVE-2017-2651](https://insights.sbomify.com/CVE-2017-2651/): Exposure of Sensitive Information to an Unauthorized Actor in Jenkins-mailer-plugin (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8718 and fix it if it is affected.

What it is: CVE-2018-8718 is a high-severity vulnerability in n/a, published on 27 Mar 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-8718 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.21
- org.jenkins-ci.plugins:mailer (Maven): affected all versions; fixed in 1.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8718/ (Markdown: https://insights.sbomify.com/CVE-2018-8718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8718
- OSV: https://osv.dev/vulnerability/CVE-2018-8718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8718/
Summaries are generated and may contain mistakes; the official description above is the record.
