CVE-2018-8825 Improper Restriction of Operations within the Bounds of a Memory Buffer in Google TensorFlow

High 8.8 Published Updated

A buffer overflow in TensorFlow allows local attackers to execute arbitrary code, requiring an upgrade to a patched version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-8825?

CVE-2018-8825 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 23 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Google TensorFlow 1.7 and below is affected by: Buffer Overflow. The impact is: execute arbitrary code (local).

Weakness: CWE-119

Which versions are affected by CVE-2018-8825?

7 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow PyPIAll versions1.7.1
tensorflow PyPIFrom 1.5.01.7.1
tensorflow PyPIFrom 1.5.01.7.1
tensorflow-cpu PyPIAll versions1.7.1
tensorflow-gpu PyPIAll versions1.7.1
tensorflow-gpu PyPIFrom 1.5.01.7.1
1 more packages
tensorflow-gpu PyPIFrom 1.5.01.7.1

Products include Google Tensorflow.

How do I fix CVE-2018-8825?

Upgrade tensorflow to 1.7.1 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2018-8825 being exploited?

There is no known exploitation of CVE-2018-8825 in the wild and no public exploit code.

All Google Tensorflow vulnerabilities

Sources

Also known as GHSA-frxx-2m33-6wcr, PYSEC-2019-208, PYSEC-2019-226, PYSEC-2019-233.

Is CVE-2018-8825 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free