# CVE-2018-8947: Plaintext Storage of Sensitive Information in Laravel Log Viewer before v0.13.0

> Remote attackers can bypass access restrictions and read arbitrary files by exploiting weak Base64 encoding in log viewer requests.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-63qj-p8gh-5xxx

## What is CVE-2018-8947?

CVE-2018-8947 is a high-severity path traversal vulnerability in n/a, published on 25 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

rap2hpoutre Laravel Log Viewer before v0.13.0 relies on Base64 encoding for l, dl, and del requests, which makes it easier for remote attackers to bypass intended access restrictions, as demonstrated by reading arbitrary files via a dl request.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2018-8947?

2 open source packages ship an affected version, including rap2hpoutre/laravel-log-viewer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rap2hpoutre/laravel-log-viewer` | Packagist | All versions | 0.13.0 |
| `rap2hpoutre/laravel-log-viewer` | Packagist | All versions | 0.13.0 |

Products: Laravel Log Viewer Project Laravel Log Viewer.

## How do I fix CVE-2018-8947?

Upgrade rap2hpoutre/laravel-log-viewer to 0.13.0 or later.

## Is CVE-2018-8947 being exploited?

There is no known exploitation of CVE-2018-8947 in the wild and no public exploit code.

Public exploit code:

- Laravel Log Viewer < 0.13.0 - Local File Download (exploitdb)
- https://github.com/scopion/CVE-2018-8947 (github_poc): https://github.com/scopion/CVE-2018-8947

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-8947 and fix it if it is affected.

What it is: CVE-2018-8947 is a high-severity path traversal vulnerability in n/a, published on 25 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-8947 in the wild and no public exploit code.

Affected packages and fixed versions:
- rap2hpoutre/laravel-log-viewer (Packagist): affected all versions; fixed in 0.13.0
- rap2hpoutre/laravel-log-viewer (Packagist): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-8947/ (Markdown: https://insights.sbomify.com/CVE-2018-8947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-8947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-8947
- OSV: https://osv.dev/vulnerability/CVE-2018-8947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-8947/
Summaries are generated and may contain mistakes; the official description above is the record.
