# CVE-2018-9019: Dolibarr SQL Injection vulnerability

> Remote attackers can execute arbitrary SQL commands via the sortfield parameter in multiple admin pages, potentially compromising database integrity and confidentiality.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-fff9-m6f6-q3mh, UBUNTU-CVE-2018-9019

## What is CVE-2018-9019?

CVE-2018-9019 is a critical SQL injection vulnerability in n/a, published on 22 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL Injection vulnerability in Dolibarr before version 7.0.2 allows remote attackers to execute arbitrary SQL commands via the sortfield parameter to /accountancy/admin/accountmodel.php, /accountancy/admin/categories_list.php, /accountancy/admin/journals_list.php, /admin/dict.php, /admin/mails_templates.php, or /admin/website.php.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-9019?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 7.0.2 |
| `dolibarr/dolibarr` | Packagist | All versions | 7.0.2 |

Products: Dolibarr Dolibarr, Oracle Data Integrator.

## How do I fix CVE-2018-9019?

Upgrade dolibarr/dolibarr to 7.0.2 or later.

## Is CVE-2018-9019 being exploited?

There is no known exploitation of CVE-2018-9019 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)
- [CVE-2017-14242](https://insights.sbomify.com/CVE-2017-14242/): Dolibarr SQL injection vulnerability in don/list.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-9019 and fix it if it is affected.

What it is: CVE-2018-9019 is a critical SQL injection vulnerability in n/a, published on 22 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-9019 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 7.0.2
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 7.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-9019/ (Markdown: https://insights.sbomify.com/CVE-2018-9019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-9019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-9019
- OSV: https://osv.dev/vulnerability/CVE-2018-9019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-9019/
Summaries are generated and may contain mistakes; the official description above is the record.
