CVE-2018-9160 SiCKRAGE Discloses Plaintext Credentials

Critical 9.8 Published Updated

SickRage exposes cleartext credentials in HTTP responses, allowing attackers to steal sensitive authentication data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-9160?

CVE-2018-9160 is a critical vulnerability in n/a, published on 31 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SickRage before v2018.03.09-1 includes cleartext credentials in HTTP responses.

Weakness: CWE-522

Which versions are affected by CVE-2018-9160?

3 open source packages ship an affected version, including sickrage. It affects 1 product.

PackageAffectedFixed in
sickrage PyPIAll versions2018.03.09-1
sickrage PyPIAll versions2018.03.09-1
sickrage PyPIAll versions9.3.2

Products include Sickrage Sickrage.

How do I fix CVE-2018-9160?

Upgrade sickrage to a fixed version for your release line: 2018.03.09-1 or 9.3.2.

Is CVE-2018-9160 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-9160 exists.

Public exploit code: 1 Metasploit module, 1 Exploit-DB entry and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-jrcv-3c5h-rh3q, PYSEC-2018-101.

Is CVE-2018-9160 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free