# CVE-2018-9160: SiCKRAGE Discloses Plaintext Credentials

> SickRage exposes cleartext credentials in HTTP responses, allowing attackers to steal sensitive authentication data.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jrcv-3c5h-rh3q, PYSEC-2018-101

## What is CVE-2018-9160?

CVE-2018-9160 is a critical vulnerability in n/a, published on 31 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SickRage before v2018.03.09-1 includes cleartext credentials in HTTP responses.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2018-9160?

3 open source packages ship an affected version, including sickrage. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sickrage` | PyPI | All versions | 2018.03.09-1 |
| `sickrage` | PyPI | All versions | 2018.03.09-1 |
| `sickrage` | PyPI | All versions | 9.3.2 |

Products: Sickrage Sickrage.

## How do I fix CVE-2018-9160?

Upgrade sickrage to a fixed version for your release line: 2018.03.09-1 or 9.3.2.

## Is CVE-2018-9160 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-9160 exists.

Public exploit code:

- HTTP SickRage Password Leak (metasploit)
- SickRage < v2018.03.09 - Clear-Text Credentials HTTP Response (exploitdb)
- CVE-2018-9160 (github_poc): https://github.com/mechanico/sickrageWTF

## Other vulnerabilities in n/a

- [CVE-2021-25926](https://insights.sbomify.com/CVE-2021-25926/): Cross-site scripting in sickrage (medium 6.1)
- [CVE-2021-25925](https://insights.sbomify.com/CVE-2021-25925/): Cross-site scripting in SiCKRAGE (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-9160 and fix it if it is affected.

What it is: CVE-2018-9160 is a critical vulnerability in n/a, published on 31 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-9160 exists.

Affected packages and fixed versions:
- sickrage (PyPI): affected all versions; fixed in 2018.03.09-1
- sickrage (PyPI): affected all versions; fixed in 2018.03.09-1
- sickrage (PyPI): affected all versions; fixed in 9.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-9160/ (Markdown: https://insights.sbomify.com/CVE-2018-9160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-9160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-9160
- OSV: https://osv.dev/vulnerability/CVE-2018-9160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-9160/
Summaries are generated and may contain mistakes; the official description above is the record.
