# CVE-2018-9207: Unrestricted Upload of File with Dangerous Type in jquery-file-upload

> An attacker can upload arbitrary files via the jQuery Upload File library, potentially leading to remote code execution.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mxr5-p36v-479m

## What is CVE-2018-9207?

CVE-2018-9207 is a critical vulnerability in hayageek jQuery Upload File, published on 19 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Arbitrary file upload in jQuery Upload File <= 4.0.2

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2018-9207?

2 open source packages ship an affected version, including jquery-file-upload. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jquery-file-upload` | npm | All versions | 4.0.5 |
| `jquery-file-upload` | npm | All versions | 4.0.5 |

Products: Hayageek Jquery Upload File.

## How do I fix CVE-2018-9207?

Upgrade jquery-file-upload to 4.0.5 or later.

## Is CVE-2018-9207 being exploited?

There is no known exploitation of CVE-2018-9207 in the wild and no public exploit code.

Public exploit code:

- cve-2018-9207 (github_poc): https://github.com/cved-sources/cve-2018-9207

## Other vulnerabilities in hayageek jQuery Upload File

- [CVE-2021-37504](https://insights.sbomify.com/CVE-2021-37504/): jQuery-Upload-File XSS in fileNameStr (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-9207 and fix it if it is affected.

What it is: CVE-2018-9207 is a critical vulnerability in hayageek jQuery Upload File, published on 19 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-9207 in the wild and no public exploit code.

Affected packages and fixed versions:
- jquery-file-upload (npm): affected all versions; fixed in 4.0.5
- jquery-file-upload (npm): affected all versions; fixed in 4.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-9207/ (Markdown: https://insights.sbomify.com/CVE-2018-9207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-9207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-9207
- OSV: https://osv.dev/vulnerability/CVE-2018-9207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-9207/
Summaries are generated and may contain mistakes; the official description above is the record.
