CVE-2018-9243 Cross-site scripting in n/a
Attackers can execute arbitrary scripts in victim browsers via malicious filenames in GitLab merge requests, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2018-9243?
CVE-2018-9243 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 5 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
GitLab Community and Enterprise Editions version 8.4 up to 10.4 are vulnerable to XSS because a lack of input validation in the merge request component leads to cross site scripting (specifically, filenames in changes tabs of merge requests). This is fixed in 10.6.3, 10.5.7, and 10.4.7.
Weakness: CWE-79
Which versions are affected by CVE-2018-9243?
It affects 1 product.
Products include Gitlab Gitlab.
How do I fix CVE-2018-9243?
No fix has been published for CVE-2018-9243 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-9243 being exploited?
There is no known exploitation of CVE-2018-9243 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as GHSA-7p8p-3gqp-fcqx, UBUNTU-CVE-2018-9243.