{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-9336 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-9336 is a high-severity use after free vulnerability in Slackware Slackware Linux, published on 1 May 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-9336 and fix it if it is affected.\n\nWhat it is: CVE-2018-9336 is a high-severity use after free vulnerability in Slackware Slackware Linux, published on 1 May 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-9336 in the wild and no public exploit code.\n\nAffected product: Slackware Slackware Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-9336/ (Markdown: https://insights.sbomify.com/CVE-2018-9336/index.md)","id":"CVE-2018-9336","markdown":"https://insights.sbomify.com/CVE-2018-9336/index.md","name":"CVE-2018-9336","record":{"aliases":["ALPINE-CVE-2018-9336","GHSA-9p34-3252-9gh9","MGASA-2018-0329","SUSE-SU-2018:1888-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"OpenVPN interactive service","requires_auth":"low_privilege","summary":"A local attacker can trigger a double-free in the OpenVPN interactive service, causing denial of service or potential privilege escalation.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openvpn","vendor":"openvpn"},{"product":"slackware_linux","vendor":"slackware"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-415","name":"Double Free"}],"description":"openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2018-9336","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"slackware:slackware_linux","products":["slackware:slackware_linux"],"type":"use_after_free","year":"2018"},"n_packages":1,"n_references":5,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-9337"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["2.4.3-5.3.19"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2018:1888-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-9335"},"products":["n/a"],"published":"2018-05-01","related":[{"cvss_score":9.1,"headline":"Memory corruption in OpenVPN","id":"CVE-2025-12106","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":9.1,"headline":"Information disclosure in OpenVPN","id":"CVE-2024-5594","kev_date_added":null,"published":"2025-01-06"},{"cvss_score":9.1,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-7544","kev_date_added":null,"published":"2018-03-16"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2006-1629","kev_date_added":null,"published":"2006-04-06"},{"cvss_score":8.8,"headline":"Privilege escalation in OpenVPN","id":"CVE-2024-4877","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":7.8,"headline":"Code injection in OpenVPN-GUI","id":"CVE-2021-3606","kev_date_added":null,"published":"2021-07-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A local attacker can trigger a double-free in the OpenVPN interactive service, causing denial of service or potential privilege escalation.","url":"https://insights.sbomify.com/CVE-2018-9336/"}