CVE-2018-9861 Enhanced Image plugin for CKEditor is vulnerable to Cross-site scripting (XSS)
Remote attackers can inject arbitrary web script via crafted IMG elements in the CKEditor image plugin, affecting Drupal installations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-9861?
CVE-2018-9861 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 19 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.
Weakness: CWE-79
Which versions are affected by CVE-2018-9861?
11 open source packages ship an affected version, including drupal/core, drupal/drupal and ckeditor-dev. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 8.0 | 8.4.7 |
drupal/core Packagist | From 8.0 | 8.4.7 |
drupal/core Packagist | From 8.0.0 | 8.4.7, 8.5.2 |
drupal/core Packagist | From 8.5.0 | 8.5.2 |
drupal/core Packagist | From 8.5.0 | 8.5.2 |
drupal/drupal Packagist | From 8.0 | 8.4.7 |
5 more packages
drupal/drupal Packagist | From 8.0 | 8.4.7 |
drupal/drupal Packagist | From 8.5 | 8.5.2 |
drupal/drupal Packagist | From 8.5 | 8.5.2 |
ckeditor-dev npm | From 4.5.10 | 4.9.2 |
ckeditor-dev npm | From 4.5.10 | 4.9.2 |
Products include Ckeditor Enhanced Image, Drupal Drupal.
How do I fix CVE-2018-9861?
Upgrade drupal/core to a fixed version for your release line: 8.4.7 or 8.5.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-9861 being exploited?
There is no known exploitation of CVE-2018-9861 in the wild and no public exploit code.
Sources
Also known as DRUPAL-CORE-2018-003, GHSA-g78h-pf65-46rv, UBUNTU-CVE-2018-9861.