{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-9918 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-9918 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 10 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-9918 and fix it if it is affected.\n\nWhat it is: CVE-2018-9918 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 10 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-9918 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-9918/ (Markdown: https://insights.sbomify.com/CVE-2018-9918/index.md)","id":"CVE-2018-9918","markdown":"https://insights.sbomify.com/CVE-2018-9918/index.md","name":"CVE-2018-9918","record":{"aliases":["DEBIAN-CVE-2018-9918","GHSA-mcgj-mgj8-8cr3","MGASA-2018-0232","SUSE-SU-2024:2173-1","UBUNTU-CVE-2018-9918"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"QPDF library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via stack exhaustion in QPDF due to unrestricted nesting in direct objects.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"qpdf","vendor":"qpdf_project"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"libqpdf.a in QPDF through 8.0.2 mishandles certain \"expected dictionary key but found non-name object\" cases, allowing remote attackers to cause a denial of service (stack exhaustion), related to the QPDFObjectHandle and QPDF_Dictionary classes, because nesting in direct objects is not restricted.","ecosystems":["SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-9918","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"denial_of_service","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2018-9919"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["7.1.1-3.11.1"],"introduced":["0"],"last_affected":[],"package":"qpdf","purl":"pkg:rpm/suse/qpdf\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2024:2173-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["7.1.1-3.11.1"],"introduced":["0"],"last_affected":[],"package":"qpdf","purl":"pkg:rpm/suse/qpdf\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2024:2173-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["7.1.1-3.11.1"],"introduced":["0"],"last_affected":[],"package":"qpdf","purl":"pkg:rpm/suse/qpdf\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2024:2173-1"}],"prev":{"headline":"Missing authorization in SonicOS","id":"CVE-2018-9867"},"products":["n/a"],"published":"2018-04-10","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via stack exhaustion in QPDF due to unrestricted nesting in direct objects.","url":"https://insights.sbomify.com/CVE-2018-9918/"}