{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.portals.pluto:chatRoomDemo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-0186 in the wild and no public exploit code.","fix":"Upgrade org.apache.portals.pluto:chatRoomDemo to 3.1.0 or later.","what":"CVE-2019-0186 is a medium-severity cross-site scripting vulnerability in Apache Pluto, published on 26 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-0186 and fix it if it is affected.\n\nWhat it is: CVE-2019-0186 is a medium-severity cross-site scripting vulnerability in Apache Pluto, published on 26 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-0186 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.portals.pluto:chatRoomDemo (Maven): affected from 3.0.0; fixed in 3.1.0\n- org.apache.portals.pluto:chatRoomDemo (Maven): affected from 3.0.0; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-0186/ (Markdown: https://insights.sbomify.com/CVE-2019-0186/index.md)","id":"CVE-2019-0186","markdown":"https://insights.sbomify.com/CVE-2019-0186/index.md","name":"CVE-2019-0186","record":{"aliases":["GHSA-w47g-4vrc-m3w2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Pluto demo portlet","requires_auth":"none","summary":"Cross-site scripting in the Apache Pluto Chat Room demo portlet allows attackers to inject malicious scripts into user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"pluto","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The input fields of the Apache Pluto \"Chat Room\" demo portlet 3.0.0 and 3.0.1 are vulnerable to Cross-Site Scripting (XSS) attacks. Mitigation: * Uninstall the ChatRoomDemo war file - or - * migrate to version 3.1.0 of the chat-room-demo war file","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2019-04-26","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-04-26","kind":"exploitdb","ref":"46759","stars":null,"title":"Apache Pluto 3.0.0 / 3.0.1 - Persistent Cross-Site Scripting"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cross-site Scripting in Apache Pluto Chatroom demo","id":"CVE-2019-0186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":7,"next":{"headline":"Unauthenticated Remote Code Execution in Apache JMeter","id":"CVE-2019-0187"},"packages":[{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.portals.pluto:chatRoomDemo","purl":null,"source":"GHSA-w47g-4vrc-m3w2"},{"ecosystem":"Maven","fixed":["3.1.0"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.portals.pluto:chatRoomDemo","purl":"pkg:maven/org.apache.portals.pluto/chatRoomDemo","source":"GHSA-w47g-4vrc-m3w2"}],"prev":{"headline":"Information disclosure in 2019.2 IPU – Intel(R) Processor Graphics SMM","id":"CVE-2019-0185"},"products":["Apache Pluto"],"published":"2019-04-26","related":[{"cvss_score":7.5,"headline":"Exposure of Sensitive Information in Apache Pluto","id":"CVE-2018-1306","kev_date_added":null,"published":"2018-06-27"},{"cvss_score":6.1,"headline":"XSS in V3 Demo Portlet","id":"CVE-2021-36737","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":6.1,"headline":"XSS vulnerability in the JSP version of the Apache Pluto Applicant MVCBean CDI portlet","id":"CVE-2021-36738","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":6.1,"headline":"XSS vulnerability in the MVCBean JSP portlet maven archetype","id":"CVE-2021-36739","kev_date_added":null,"published":"2022-01-06"},{"cvss_score":4.4,"headline":"Information disclosure in JUnit4","id":"CVE-2020-15250","kev_date_added":null,"published":"2020-10-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"Cross-site scripting in the Apache Pluto Chat Room demo portlet allows attackers to inject malicious scripts into user sessions.","url":"https://insights.sbomify.com/CVE-2019-0186/"}