{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.jmeter:ApacheJMeter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-0187 in the wild and no public exploit code.","fix":"Upgrade org.apache.jmeter:ApacheJMeter to 5.1 or later.","what":"CVE-2019-0187 is a critical unsafe deserialization vulnerability in Apache JMeter, published on 6 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-0187 and fix it if it is affected.\n\nWhat it is: CVE-2019-0187 is a critical unsafe deserialization vulnerability in Apache JMeter, published on 6 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-0187 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.jmeter:ApacheJMeter (Maven): affected all versions; fixed in 5.1\n- org.apache.jmeter:ApacheJMeter (Maven): affected all versions; fixed in 5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-0187/ (Markdown: https://insights.sbomify.com/CVE-2019-0187/index.md)","id":"CVE-2019-0187","markdown":"https://insights.sbomify.com/CVE-2019-0187/index.md","name":"CVE-2019-0187","record":{"aliases":["DEBIAN-CVE-2019-0187","GHSA-wg37-7mrv-cfwm","UBUNTU-CVE-2019-0187"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache JMeter","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary code via unsafe deserialization when JMeter runs in distributed mode.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"jmeter","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unauthenticated Remote Code Execution in Apache JMeter","id":"CVE-2019-0187","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"XML External Entity injection in Apache Camel","id":"CVE-2019-0188"},"packages":[{"ecosystem":"Maven","fixed":["5.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.jmeter:ApacheJMeter","purl":null,"source":"GHSA-wg37-7mrv-cfwm"},{"ecosystem":"Maven","fixed":["5.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.jmeter:ApacheJMeter","purl":"pkg:maven/org.apache.jmeter/ApacheJMeter","source":"GHSA-wg37-7mrv-cfwm"}],"prev":{"headline":"Cross-site Scripting in Apache Pluto Chatroom demo","id":"CVE-2019-0186"},"products":["Apache JMeter"],"published":"2019-03-06","related":[{"cvss_score":9.8,"headline":"Missing certificate validation in Apache JMeter","id":"CVE-2018-1287","kev_date_added":null,"published":"2018-02-14"},{"cvss_score":9.8,"headline":"Missing certificate validation in Apache JMeter","id":"CVE-2018-1297","kev_date_added":null,"published":"2018-02-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Unauthenticated attackers can execute arbitrary code via unsafe deserialization when JMeter runs in distributed mode.","url":"https://insights.sbomify.com/CVE-2019-0187/"}