# CVE-2019-0187: Unauthenticated Remote Code Execution in Apache JMeter

> Unauthenticated attackers can execute arbitrary code via unsafe deserialization when JMeter runs in distributed mode.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2019
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2019-0187, GHSA-wg37-7mrv-cfwm, UBUNTU-CVE-2019-0187

## What is CVE-2019-0187?

CVE-2019-0187 is a critical unsafe deserialization vulnerability in Apache JMeter, published on 6 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2019-0187?

2 open source packages ship an affected version, including org.apache.jmeter:ApacheJMeter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jmeter:ApacheJMeter` | Maven | All versions | 5.1 |
| `org.apache.jmeter:ApacheJMeter` | Maven | All versions | 5.1 |

Products: Apache Jmeter.

## How do I fix CVE-2019-0187?

Upgrade org.apache.jmeter:ApacheJMeter to 5.1 or later.

## Is CVE-2019-0187 being exploited?

There is no known exploitation of CVE-2019-0187 in the wild and no public exploit code.

## Other vulnerabilities in Apache JMeter

- [CVE-2018-1287](https://insights.sbomify.com/CVE-2018-1287/): Missing certificate validation in Apache JMeter (critical 9.8)
- [CVE-2018-1297](https://insights.sbomify.com/CVE-2018-1297/): Missing certificate validation in Apache JMeter (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0187 and fix it if it is affected.

What it is: CVE-2019-0187 is a critical unsafe deserialization vulnerability in Apache JMeter, published on 6 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0187 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jmeter:ApacheJMeter (Maven): affected all versions; fixed in 5.1
- org.apache.jmeter:ApacheJMeter (Maven): affected all versions; fixed in 5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0187/ (Markdown: https://insights.sbomify.com/CVE-2019-0187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0187
- OSV: https://osv.dev/vulnerability/CVE-2019-0187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0187/
Summaries are generated and may contain mistakes; the official description above is the record.
