# CVE-2019-0191: Moderate severity vulnerability that affects org.apache.karaf:apache-karaf and org.apache.karaf:karaf

> Attackers can write arbitrary files to the filesystem via malicious .kar archives due to lack of path validation in Apache Karaf.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-869j-5855-hjpm

## What is CVE-2019-0191?

CVE-2019-0191 is a medium-severity path traversal vulnerability in Apache Karaf, published on 20 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Karaf kar deployer reads .kar archives and extracts the paths from the "repository/" and "resources/" entries in the zip file. It then writes out the content of these paths to the Karaf repo and resources directories. However, it doesn't do any validation on the paths in the zip file. This means that a malicious user could craft a .kar file with ".." directory names and break out of the directories to write arbitrary content to the filesystem. This is the "Zip-slip" vulnerability - https://snyk.io/research/zip-slip-vulnerability. This vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf releases prior 4.2.3 is impacted.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-0191?

4 open source packages ship an affected version, including org.apache.karaf:apache-karaf and org.apache.karaf:karaf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 4.2.3 |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 4.2.3 |
| `org.apache.karaf:karaf` | Maven | All versions | 4.2.3 |
| `org.apache.karaf:karaf` | Maven | All versions | 4.2.3 |

Products: Apache Karaf.

## How do I fix CVE-2019-0191?

Upgrade org.apache.karaf:apache-karaf to 4.2.3 or later.

## Is CVE-2019-0191 being exploited?

There is no known exploitation of CVE-2019-0191 in the wild and no public exploit code.

## Other vulnerabilities in Apache Karaf

- [CVE-2026-91012](https://insights.sbomify.com/CVE-2026-91012/): Apache Karaf: Path Traversal in Config Service Allows Manager-to-Admin Privilege Escalation (critical 9.8)
- [CVE-2026-91048](https://insights.sbomify.com/CVE-2026-91048/): Missing authorization in Apache Karaf (critical 9.8)
- [CVE-2022-40145](https://insights.sbomify.com/CVE-2022-40145/): Apache Karaf: JDBC JAAS LDAP injection (critical 9.8)
- [CVE-2018-11788](https://insights.sbomify.com/CVE-2018-11788/): XML External Entity Reference in Apache Karaf (critical 9.8)
- [CVE-2026-92142](https://insights.sbomify.com/CVE-2026-92142/): Apache Karaf: Authorization bypass in JMX MBean lifecycle operations (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0191 and fix it if it is affected.

What it is: CVE-2019-0191 is a medium-severity path traversal vulnerability in Apache Karaf, published on 20 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0191 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 4.2.3
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 4.2.3
- org.apache.karaf:karaf (Maven): affected all versions; fixed in 4.2.3
- org.apache.karaf:karaf (Maven): affected all versions; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0191/ (Markdown: https://insights.sbomify.com/CVE-2019-0191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0191
- OSV: https://osv.dev/vulnerability/CVE-2019-0191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0191/
Summaries are generated and may contain mistakes; the official description above is the record.
