# CVE-2019-0192: Critical severity vulnerability that affects org.apache.solr:solr-core

> An attacker can achieve remote code execution on Apache Solr by exploiting unsafe deserialization in the Config API via a malicious RMI server.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xhcq-fv7x-grr2, UBUNTU-CVE-2019-0192

## What is CVE-2019-0192?

CVE-2019-0192 is a critical unsafe deserialization vulnerability in Netapp Storage Automation Store, published on 7 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-0192?

4 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 5.0.0 | 7.0.0 |
| `org.apache.solr:solr-core` | Maven | From 5.0.0 | 7.0.0 |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 7.0.0 |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 7.0.0 |

Products: Apache Solr, Netapp Storage Automation Store.

## How do I fix CVE-2019-0192?

Upgrade org.apache.solr:solr-core to 7.0.0 or later.

## Is CVE-2019-0192 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-0192 exists.

Public exploit code:

- RCE on Apache Solr using deserialization of untrusted data via jmx.serviceUrl (github_poc): https://github.com/mpgn/CVE-2019-0192
- Apache Solr remote code execution via dataImportHandler (github_poc): https://github.com/Rapidsafeguard/Solr-RCE-CVE-2019-0192
- Apache Solr - Deserialization of Untrusted Data (nuclei): http/cves/2019/CVE-2019-0192.yaml

## Other vulnerabilities in Netapp Storage Automation Store

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0192 and fix it if it is affected.

What it is: CVE-2019-0192 is a critical unsafe deserialization vulnerability in Netapp Storage Automation Store, published on 7 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-0192 exists.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 5.0.0; fixed in 7.0.0
- org.apache.solr:solr-core (Maven): affected from 5.0.0; fixed in 7.0.0
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 7.0.0
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0192/ (Markdown: https://insights.sbomify.com/CVE-2019-0192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0192
- OSV: https://osv.dev/vulnerability/CVE-2019-0192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0192/
Summaries are generated and may contain mistakes; the official description above is the record.
