# CVE-2019-0193: Apache Solr DataImportHandler Code Injection

> Attackers can execute arbitrary code via the DataImportHandler dataConfig parameter if debug mode is enabled, requiring specific configuration to mitigate.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 10 Dec 2021 (CISA KEV)
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2019
- **Updated:** 21 Oct 2025
- **Also known as:** DEBIAN-CVE-2019-0193, DLA-1954-1, DLA-2327-1, GHSA-3gm7-v7vw-866c, UBUNTU-CVE-2019-0193, USN-7283-1

## What is CVE-2019-0193?

CVE-2019-0193 is a high-severity code injection vulnerability in Debian Debian Linux, published on 1 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Apache Solr, the DataImportHandler, an optional but popular module to pull in data from databases and other sources, has a feature in which the whole DIH configuration can come from a request's "dataConfig" parameter. The debug mode of the DIH admin screen uses this to allow convenient debugging / development of a DIH config. Since a DIH config can contain scripts, this parameter is a security risk. Starting with version 8.2.0 of Solr, use of this parameter requires setting the Java System property "enable.dih.dataConfigParam" to true.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2019-0193?

2 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | 8.2.0 |
| `org.apache.solr:solr-core` | Maven | All versions | 8.2.0 |

Products: Apache Solr, Debian Debian Linux.

## How do I fix CVE-2019-0193?

Upgrade org.apache.solr:solr-core to 8.2.0 or later. US federal agencies must fix it by 10 Jun 2022.

## Is CVE-2019-0193 being exploited?

Yes. Attackers have exploited CVE-2019-0193 in the wild since at least 10 Dec 2021.

Public exploit code:

- Apache Solr DataImport Handler RCE (github_poc): https://github.com/jas502n/CVE-2019-0193
- Apache Solr远程代码执行漏洞(CVE-2019-0193) Exploit (github_poc): https://github.com/1135/solr_exploit
- https://github.com/xConsoIe/CVE-2019-0193 (github_poc): https://github.com/xConsoIe/CVE-2019-0193
- https://github.com/jaychouzzk/CVE-2019-0193-exp (github_poc): https://github.com/jaychouzzk/CVE-2019-0193-exp
- ApacheSolrRCE（CVE-2019-0193）一键写shell，原理是通过代码执行的java文件流写的马。 (github_poc): https://github.com/freeFV/ApacheSolrRCE
- Apache Solr DataImportHandler <8.2.0 - Remote Code Execution (nuclei): http/cves/2019/CVE-2019-0193.yaml

## Other vulnerabilities in Debian Debian Linux

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)
- [CVE-2020-13957](https://insights.sbomify.com/CVE-2020-13957/): Incorrect Authorization in Apache Solr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0193 and fix it if it is affected.

What it is: CVE-2019-0193 is a high-severity code injection vulnerability in Debian Debian Linux, published on 1 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2019-0193 in the wild since at least 10 Dec 2021.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 8.2.0
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 8.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0193/ (Markdown: https://insights.sbomify.com/CVE-2019-0193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0193
- OSV: https://osv.dev/vulnerability/CVE-2019-0193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0193/
Summaries are generated and may contain mistakes; the official description above is the record.
