# CVE-2019-0200: Improper Input Validation in Apache Qpid Broker-J

> Unauthenticated attackers can crash the Apache Qpid Broker-J instance by sending specially crafted AMQP commands, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-c9h6-xhg9-xxrv

## What is CVE-2019-0200?

CVE-2019-0200 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 6 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 which allows an unauthenticated attacker to crash the broker instance by sending specially crafted commands using AMQP protocol versions below 1.0 (AMQP 0-8, 0-9, 0-91 and 0-10). Users of Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 utilizing AMQP protocols 0-8, 0-9, 0-91, 0-10 must upgrade to Qpid Broker-J versions 7.0.7 or 7.1.1 or later.

## Which versions are affected by CVE-2019-0200?

4 open source packages ship an affected version, including org.apache.qpid:apache-qpid-broker-j. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.qpid:apache-qpid-broker-j` | Maven | All versions | 7.0.7 |
| `org.apache.qpid:apache-qpid-broker-j` | Maven | All versions | 7.0.7 |
| `org.apache.qpid:apache-qpid-broker-j` | Maven | From 7.1.0 | 7.1.1 |
| `org.apache.qpid:apache-qpid-broker-j` | Maven | From 7.1.0 | 7.1.1 |

Products: Apache Qpid Broker-J.

## How do I fix CVE-2019-0200?

Upgrade org.apache.qpid:apache-qpid-broker-j to a fixed version for your release line: 7.0.7 or 7.1.1.

## Is CVE-2019-0200 being exploited?

There is no known exploitation of CVE-2019-0200 in the wild and no public exploit code.

## Other vulnerabilities in Apache Qpid Broker-J

- [CVE-2026-92609](https://insights.sbomify.com/CVE-2026-92609/): Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication (critical 9.8)
- [CVE-2017-15702](https://insights.sbomify.com/CVE-2017-15702/): Apache Qpid Broker vulnerable to authentication port spoofing (critical 9.8)
- [CVE-2016-4432](https://insights.sbomify.com/CVE-2016-4432/): AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication (critical 9.1)
- [CVE-2026-92550](https://insights.sbomify.com/CVE-2026-92550/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92560](https://insights.sbomify.com/CVE-2026-92560/): Denial of service in Apache Qpid Broker-J (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0200 and fix it if it is affected.

What it is: CVE-2019-0200 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 6 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0200 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.qpid:apache-qpid-broker-j (Maven): affected all versions; fixed in 7.0.7
- org.apache.qpid:apache-qpid-broker-j (Maven): affected all versions; fixed in 7.0.7
- org.apache.qpid:apache-qpid-broker-j (Maven): affected from 7.1.0; fixed in 7.1.1
- org.apache.qpid:apache-qpid-broker-j (Maven): affected from 7.1.0; fixed in 7.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0200/ (Markdown: https://insights.sbomify.com/CVE-2019-0200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0200
- OSV: https://osv.dev/vulnerability/CVE-2019-0200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0200/
Summaries are generated and may contain mistakes; the official description above is the record.
