CVE-2019-0202 Exposure of Sensitive Information in Apache Storm Logviewer

High 7.5 Published Updated

Attackers can read arbitrary files from the host file system via the Apache Storm Logviewer HTTP endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-0202?

CVE-2019-0202 is a high-severity path traversal vulnerability in Apache Storm, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Apache Storm Logviewer daemon exposes HTTP-accessible endpoints to read/search log files on hosts running Storm. In Apache Storm versions 0.9.1-incubating to 1.2.2, it is possible to read files off the host's file system that were not intended to be accessible via these endpoints.

Weakness: CWE-532, CWE-200

Which versions are affected by CVE-2019-0202?

2 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.

PackageAffectedFixed in
org.apache.storm:storm-core MavenFrom 0.9.1-incubating1.2.3
org.apache.storm:storm-core MavenFrom 0.9.1-incubating1.2.3

Products include Apache Storm.

How do I fix CVE-2019-0202?

Upgrade org.apache.storm:storm-core to 1.2.3 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2019-0202 being exploited?

There is no known exploitation of CVE-2019-0202 in the wild and no public exploit code.

Sources

Also known as GHSA-r9pv-hg64-jqrp.

Is CVE-2019-0202 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free