# CVE-2019-0202: Exposure of Sensitive Information in Apache Storm Logviewer

> Attackers can read arbitrary files from the host file system via the Apache Storm Logviewer HTTP endpoints.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-r9pv-hg64-jqrp

## What is CVE-2019-0202?

CVE-2019-0202 is a high-severity path traversal vulnerability in Apache Storm, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Storm Logviewer daemon exposes HTTP-accessible endpoints to read/search log files on hosts running Storm. In Apache Storm versions 0.9.1-incubating to 1.2.2, it is possible to read files off the host's file system that were not intended to be accessible via these endpoints.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-0202?

2 open source packages ship an affected version, including org.apache.storm:storm-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-core` | Maven | From 0.9.1-incubating | 1.2.3 |
| `org.apache.storm:storm-core` | Maven | From 0.9.1-incubating | 1.2.3 |

Products: Apache Storm.

## How do I fix CVE-2019-0202?

Upgrade org.apache.storm:storm-core to 1.2.3 or later.

## Is CVE-2019-0202 being exploited?

There is no known exploitation of CVE-2019-0202 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0202 and fix it if it is affected.

What it is: CVE-2019-0202 is a high-severity path traversal vulnerability in Apache Storm, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0202 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-core (Maven): affected from 0.9.1-incubating; fixed in 1.2.3
- org.apache.storm:storm-core (Maven): affected from 0.9.1-incubating; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0202/ (Markdown: https://insights.sbomify.com/CVE-2019-0202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0202
- OSV: https://osv.dev/vulnerability/CVE-2019-0202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0202/
Summaries are generated and may contain mistakes; the official description above is the record.
