# CVE-2019-0205: Loop with Unreachable Exit Condition in Apache Thrift

> Attackers can cause an endless loop in Apache Thrift servers or clients by sending specific input data, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2019
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-41158, CLEANSTART-2026-NW75737, CLEANSTART-2026-SI46546, DEBIAN-CVE-2019-0205, ECHO-e6d1-fbd8-f61d, GHSA-rj7p-rfgp-852x, MINI-8332-gjwq-8p98, MINI-jgm5-649c-rcvx, MINI-w9pf-xxrf-chf8

## What is CVE-2019-0205?

CVE-2019-0205 is a high-severity denial of service vulnerability in Redhat Jboss Enterprise Application Platform, published on 28 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Thrift all versions up to and including 0.12.0, a server or client may run into an endless loop when feed with specific input data. Because the issue had already been partially fixed in version 0.11.0, depending on the installed version it affects only certain language bindings.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2019-0205?

2 open source packages ship an affected version, including org.apache.thrift:libthrift. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.thrift:libthrift` | Maven | All versions | 0.13.0 |
| `org.apache.thrift:libthrift` | Maven | All versions | 0.13.0 |

Products: Apache Thrift, Oracle Communications Cloud Native Core Network Slice Selection Function, Redhat Jboss Enterprise Application Platform.

## How do I fix CVE-2019-0205?

Upgrade org.apache.thrift:libthrift to 0.13.0 or later.

## Is CVE-2019-0205 being exploited?

There is no known exploitation of CVE-2019-0205 in the wild and no public exploit code.

Public exploit code:

- Software-only security research on the Amazon Echo Dot 3rd Gen (doebrite): pre-auth DoS (CVE-2019-0205), SSRF, root SOCKS5, WhisperJoin BLE reversed, and a proof that no custom firmware can be installed over the air. (github_poc): https://github.com/cgarrot/echo-dot-3-doebrite-research

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0205 and fix it if it is affected.

What it is: CVE-2019-0205 is a high-severity denial of service vulnerability in Redhat Jboss Enterprise Application Platform, published on 28 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0205 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.thrift:libthrift (Maven): affected all versions; fixed in 0.13.0
- org.apache.thrift:libthrift (Maven): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0205/ (Markdown: https://insights.sbomify.com/CVE-2019-0205/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0205
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0205
- OSV: https://osv.dev/vulnerability/CVE-2019-0205

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0205/
Summaries are generated and may contain mistakes; the official description above is the record.
