{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.archiva:archiva. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-0213 in the wild and no public exploit code.","fix":"Upgrade org.apache.archiva:archiva to 2.2.4 or later.","what":"CVE-2019-0213 is a medium-severity cross-site scripting vulnerability in Apache Archiva, published on 30 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-0213 and fix it if it is affected.\n\nWhat it is: CVE-2019-0213 is a medium-severity cross-site scripting vulnerability in Apache Archiva, published on 30 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-0213 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.4\n- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-0213/ (Markdown: https://insights.sbomify.com/CVE-2019-0213/index.md)","id":"CVE-2019-0213","markdown":"https://insights.sbomify.com/CVE-2019-0213/index.md","name":"CVE-2019-0213","record":{"aliases":["GHSA-cqcf-4g4h-rghf"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Archiva","requires_auth":"low_privilege","summary":"An attacker with admin privileges or network access can inject malicious scripts into Archiva configuration entries, potentially compromising user sessions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"archiva","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Apache Archiva before 2.2.4, it may be possible to store malicious XSS code into central configuration entries, i.e. the logo URL. The vulnerability is considered as minor risk, as only users with admin role can change the configuration, or the communication between the browser and the Archiva server must be compromised.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in Apache Archiva","id":"CVE-2019-0213","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":9,"next":{"headline":"Improper Input Validation in Apache Archiva","id":"CVE-2019-0214"},"packages":[{"ecosystem":"Maven","fixed":["2.2.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.archiva:archiva","purl":null,"source":"GHSA-cqcf-4g4h-rghf"},{"ecosystem":"Maven","fixed":["2.2.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.archiva:archiva","purl":"pkg:maven/org.apache.archiva/archiva","source":"GHSA-cqcf-4g4h-rghf"}],"prev":{"headline":"Improper Authorization in org.apache.hbase:hbase","id":"CVE-2019-0212"},"products":["Apache Archiva"],"published":"2019-04-30","related":[{"cvss_score":9.8,"headline":"Apache Struts Improper Input Validation","id":"CVE-2013-2251","kev_date_added":"2022-03-25","published":"2013-07-18"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2016-4469","kev_date_added":null,"published":"2016-07-28"},{"cvss_score":8,"headline":"Apache Archiva vulnerable to Cross Site Request Forgery","id":"CVE-2017-5657","kev_date_added":null,"published":"2017-05-22"},{"cvss_score":7.5,"headline":"Apache Archiva: disabling user registration is not effective","id":"CVE-2024-27138","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":7.5,"headline":"Apache Archiva: incorrect authentication potentially leading to account takeover","id":"CVE-2024-27139","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":7.5,"headline":"Apache Archiva prior to 2.2.9 may allow the anonymous user to read arbitrary files","id":"CVE-2022-40308","kev_date_added":null,"published":"2022-11-15"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2011-1026","kev_date_added":null,"published":"2011-06-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache"]},"summary":"An attacker with admin privileges or network access can inject malicious scripts into Archiva configuration entries, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2019-0213/"}