# CVE-2019-0222: Improper Control of Generation of Code ('Code Injection') in org.apache.activemq:activemq-client

> Attackers can crash the Apache ActiveMQ broker by sending corrupt MQTT frames, causing an Out of Memory exception and service unavailability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-0222, DLA-2582-1, GHSA-jpv3-g4cc-6vfx, UBUNTU-CVE-2019-0222, USN-6685-1

## What is CVE-2019-0222?

CVE-2019-0222 is a high-severity denial of service vulnerability in Apache Activemq, published on 28 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache ActiveMQ 5.0.0 - 5.15.8, unmarshalling corrupt MQTT frame can lead to broker Out of Memory exception making it unresponsive.

## Which versions are affected by CVE-2019-0222?

2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.15.9 |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.15.9 |

Products: Apache Activemq, Debian Debian Linux, Netapp E-Series Santricity Web Services, Oracle Communications Diameter Signaling Router, Oracle Enterprise Manager Base Platform, Oracle Enterprise Repository, Oracle Goldengate Stream Analytics, Oracle Identity Manager Connector.

## How do I fix CVE-2019-0222?

Upgrade org.apache.activemq:activemq-client to 5.15.9 or later.

## Is CVE-2019-0222 being exploited?

There is no known exploitation of CVE-2019-0222 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/apache__activemq_CVE-2019-0222_5-15-8 (github_poc): https://github.com/shoucheng3/apache__activemq_CVE-2019-0222_5-15-8

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0222 and fix it if it is affected.

What it is: CVE-2019-0222 is a high-severity denial of service vulnerability in Apache Activemq, published on 28 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0222 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.15.9
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.15.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0222/ (Markdown: https://insights.sbomify.com/CVE-2019-0222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0222
- OSV: https://osv.dev/vulnerability/CVE-2019-0222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0222/
Summaries are generated and may contain mistakes; the official description above is the record.
