# CVE-2019-0225: Improper Limitation of a Pathname ('Path Traversal') in org.apache.jspwiki:jspwiki-war

> Attackers can use crafted URLs to access files under the root directory, exposing registered user details in Apache JSPWiki.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pffw-p2q5-w6vh

## What is CVE-2019-0225?

CVE-2019-0225 is a high-severity path traversal vulnerability in Apache JSPWiki, published on 28 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A specially crafted url could be used to access files under the ROOT directory of the application on Apache JSPWiki 2.9.0 to 2.11.0.M2, which could be used by an attacker to obtain registered users' details.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-0225?

2 open source packages ship an affected version, including org.apache.jspwiki:jspwiki-war. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jspwiki:jspwiki-war` | Maven | From 2.9.0 | 2.11.0.M3 |
| `org.apache.jspwiki:jspwiki-war` | Maven | From 2.9.0 | 2.11.0.M3 |

Products: Apache Jspwiki.

## How do I fix CVE-2019-0225?

Upgrade org.apache.jspwiki:jspwiki-war to 2.11.0.M3 or later.

## Is CVE-2019-0225 being exploited?

There is no known exploitation of CVE-2019-0225 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/apache__jspwiki_CVE-2019-0225_2-11-0-M2 (github_poc): https://github.com/shoucheng3/apache__jspwiki_CVE-2019-0225_2-11-0-M2

## Other vulnerabilities in Apache JSPWiki

- [CVE-2026-28812](https://insights.sbomify.com/CVE-2026-28812/): Apache JSPWiki: UserManager does not sanity-check user database at startup (critical 9.8)
- [CVE-2021-44140](https://insights.sbomify.com/CVE-2021-44140/): Arbitrary file deletion on logout (critical 9.1)
- [CVE-2026-28813](https://insights.sbomify.com/CVE-2026-28813/): Apache JSPWiki: JSPWiki vulnerable to JSON hijacking (high 8.8)
- [CVE-2022-34158](https://insights.sbomify.com/CVE-2022-34158/): User Group Privilege Escalation (high 8.8)
- [CVE-2022-24947](https://insights.sbomify.com/CVE-2022-24947/): Apache JSPWiki CSRF Account Takeover (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0225 and fix it if it is affected.

What it is: CVE-2019-0225 is a high-severity path traversal vulnerability in Apache JSPWiki, published on 28 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0225 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jspwiki:jspwiki-war (Maven): affected from 2.9.0; fixed in 2.11.0.M3
- org.apache.jspwiki:jspwiki-war (Maven): affected from 2.9.0; fixed in 2.11.0.M3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0225/ (Markdown: https://insights.sbomify.com/CVE-2019-0225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0225
- OSV: https://osv.dev/vulnerability/CVE-2019-0225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0225/
Summaries are generated and may contain mistakes; the official description above is the record.
