# CVE-2019-0228: Vulnerability that affects org.apache.pdfbox:pdfbox

> Attackers can exploit improper XML parser initialization in Apache PDFBox to perform XXE attacks via crafted XFDF files, leading to data exposure or service disruption.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-c9jj-3wvg-q65h

## What is CVE-2019-0228?

CVE-2019-0228 is a critical vulnerability in Fedoraproject Fedora, published on 17 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache PDFBox 2.0.14 does not properly initialize the XML parser, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted XFDF.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-0228?

2 open source packages ship an affected version, including org.apache.pdfbox:pdfbox. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pdfbox:pdfbox` | Maven | From 2.0.14 | 2.0.15 |
| `org.apache.pdfbox:pdfbox` | Maven | From 2.0.14 | 2.0.15 |

Products: Apache James, Apache Pdfbox, Fedoraproject Fedora, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management, Oracle Banking Supply Chain Finance, Oracle Banking Trade Finance Process Management, Oracle Banking Virtual Account Management, Oracle Communications Messaging Server, Oracle Communications Session Report Manager, Oracle Hyperion Financial Reporting, Oracle Peoplesoft Enterprise Peopletools, Oracle Retail Xstore Point of Service, Oracle Webcenter Sites.

## How do I fix CVE-2019-0228?

Upgrade org.apache.pdfbox:pdfbox to 2.0.15 or later.

## Is CVE-2019-0228 being exploited?

There is no known exploitation of CVE-2019-0228 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2023-51518](https://insights.sbomify.com/CVE-2023-51518/): Apache James server: Privilege escalation via JMX pre-authentication deserialisation (critical 9.8)
- [CVE-2021-40525](https://insights.sbomify.com/CVE-2021-40525/): Sieve file storage vulnerable to path traversal attacks (critical 9.1)
- [CVE-2023-26269](https://insights.sbomify.com/CVE-2023-26269/): Apache James server: Privilege escalation through unauthenticated JMX (high 7.8)
- [CVE-2006-2806](https://insights.sbomify.com/CVE-2006-2806/): Denial of service in n/a (high 7.8)
- [CVE-2022-28220](https://insights.sbomify.com/CVE-2022-28220/): STARTTLS command injection in Apache JAMES (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0228 and fix it if it is affected.

What it is: CVE-2019-0228 is a critical vulnerability in Fedoraproject Fedora, published on 17 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0228 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pdfbox:pdfbox (Maven): affected from 2.0.14; fixed in 2.0.15
- org.apache.pdfbox:pdfbox (Maven): affected from 2.0.14; fixed in 2.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0228/ (Markdown: https://insights.sbomify.com/CVE-2019-0228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0228
- OSV: https://osv.dev/vulnerability/CVE-2019-0228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0228/
Summaries are generated and may contain mistakes; the official description above is the record.
