{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 5 products.","exploited":"There is no known exploitation of CVE-2019-0233 in the wild and no public exploit code.","fix":"Upgrade org.apache.struts:struts2-core to 2.5.22 or later.","what":"CVE-2019-0233 is a high-severity denial of service vulnerability in Apache Struts, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-0233 and fix it if it is affected.\n\nWhat it is: CVE-2019-0233 is a high-severity denial of service vulnerability in Apache Struts, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-0233 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.22\n- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-0233/ (Markdown: https://insights.sbomify.com/CVE-2019-0233/index.md)","id":"CVE-2019-0233","markdown":"https://insights.sbomify.com/CVE-2019-0233/index.md","name":"CVE-2019-0233","record":{"aliases":["GHSA-ccp5-gg58-pxfm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"An access permission override in Apache Struts allows attackers to cause a Denial of Service during file upload operations.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"struts","vendor":"apache"},{"product":"communications_policy_management","vendor":"oracle"},{"product":"financial_services_data_integration_hub","vendor":"oracle"},{"product":"financial_services_market_risk_measurement_and_management","vendor":"oracle"},{"product":"mysql_enterprise_monitor","vendor":"oracle"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-281","name":"Improper Preservation of Permissions"}],"description":"An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Preservation of Permissions in Apache Struts","id":"CVE-2019-0233","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:struts","products":["apache:struts","oracle:communications_policy_management","oracle:mysql_enterprise_monitor"],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting in Apache Roller","id":"CVE-2019-0234"},"packages":[{"ecosystem":"Maven","fixed":["2.5.22"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":null,"source":"GHSA-ccp5-gg58-pxfm"},{"ecosystem":"Maven","fixed":["2.5.22"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","source":"GHSA-ccp5-gg58-pxfm"}],"prev":{"headline":"Apache Tomcat OS Command Injection vulnerability","id":"CVE-2019-0232"},"products":["Apache Struts"],"published":"2020-09-14","related":[{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2020-17530","kev_date_added":"2021-11-03","published":"2020-12-11"},{"cvss_score":9.8,"headline":"Apache Struts 1 Improper Input Validation","id":"CVE-2017-9791","kev_date_added":"2022-02-10","published":"2017-07-10"},{"cvss_score":9.8,"headline":"Apache Struts Remote Code Execution","id":"CVE-2017-5638","kev_date_added":"2021-11-03","published":"2017-03-11"},{"cvss_score":9.8,"headline":"Apache Struts 2 Improper Input Validation","id":"CVE-2012-0391","kev_date_added":"2022-01-21","published":"2012-01-08"},{"cvss_score":8.1,"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776","kev_date_added":"2021-11-03","published":"2018-08-22"},{"cvss_score":8.1,"headline":"Apache Struts Deserialization of Untrusted Data","id":"CVE-2017-9805","kev_date_added":"2021-11-03","published":"2017-09-15"},{"cvss_score":8.1,"headline":"Apache Struts Command Injection","id":"CVE-2016-3081","kev_date_added":"2026-10-08","published":"2016-04-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An access permission override in Apache Struts allows attackers to cause a Denial of Service during file upload operations.","url":"https://insights.sbomify.com/CVE-2019-0233/"}