# CVE-2019-0233: Improper Preservation of Permissions in Apache Struts

> An access permission override in Apache Struts allows attackers to cause a Denial of Service during file upload operations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ccp5-gg58-pxfm

## What is CVE-2019-0233?

CVE-2019-0233 is a high-severity denial of service vulnerability in Apache Struts, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2019-0233?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.22 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.5.22 |

Products: Apache Struts, Oracle Communications Policy Management, Oracle Financial Services Data Integration Hub, Oracle Financial Services Market Risk Measurement and Management, Oracle Mysql Enterprise Monitor.

## How do I fix CVE-2019-0233?

Upgrade org.apache.struts:struts2-core to 2.5.22 or later.

## Is CVE-2019-0233 being exploited?

There is no known exploitation of CVE-2019-0233 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0233 and fix it if it is affected.

What it is: CVE-2019-0233 is a high-severity denial of service vulnerability in Apache Struts, published on 14 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-0233 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.22
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.5.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0233/ (Markdown: https://insights.sbomify.com/CVE-2019-0233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0233
- OSV: https://osv.dev/vulnerability/CVE-2019-0233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0233/
Summaries are generated and may contain mistakes; the official description above is the record.
