# CVE-2019-0993: Chakra Scripting Engine Memory Corruption Vulnerability

> Remote attackers can execute arbitrary code via a crafted website in Microsoft Edge, potentially gaining full system control if the user has admin rights.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N/E:P/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2019
- **Updated:** 20 May 2025
- **Also known as:** GHSA-2rfj-2mwp-787v

## What is CVE-2019-0993?

CVE-2019-0993 is a medium-severity memory corruption vulnerability in Microsoft Chakracore, published on 12 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A remote code execution vulnerability exists in the way that the Chakra scripting engine handles objects in memory in Microsoft Edge (HTML-based). The vulnerability could corrupt memory in such a way that an attacker could execute arbitrary code in the context of the current user. An attacker who successfully exploited the vulnerability could gain the same user rights as the current user. If the current user is logged on with administrative user rights, an attacker who successfully exploited the vulnerability could take control of an affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.
In a web-based attack scenario, an attacker could host a specially crafted website that is designed to exploit the vulnerability through Microsoft Edge (HTML-based) and then convince a user to view the website. The attacker could also take advantage of compromised websites and websites that accept or host user-provided content or advertisements. These websites could contain specially crafted content that could exploit the vulnerability.
The security update addresses the vulnerability by modifying how the Chakra scripting engine handles objects in memory.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2019-0993?

2 open source packages ship an affected version, including Microsoft.ChakraCore. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.ChakraCore` | NuGet | All versions | 1.11.10 |
| `Microsoft.ChakraCore` | NuGet | All versions | 1.11.10 |

Products: Microsoft Chakracore, Microsoft Edge.

## How do I fix CVE-2019-0993?

Upgrade Microsoft.ChakraCore to 1.11.10 or later.

## Is CVE-2019-0993 being exploited?

There is no known exploitation of CVE-2019-0993 in the wild and no public exploit code.

## Other vulnerabilities in Microsoft Chakracore

- [CVE-2018-8298](https://insights.sbomify.com/CVE-2018-8298/): ChakraCore Scripting Engine Type Confusion (high 7.5, exploited in the wild)
- [CVE-2020-0878](https://insights.sbomify.com/CVE-2020-0878/): Microsoft Edge and Internet Explorer Memory Corruption (medium 4.2, exploited in the wild)
- [CVE-2018-8500](https://insights.sbomify.com/CVE-2018-8500/): ChakraCore RCE Vulnerability (critical 9.8)
- [CVE-2017-11767](https://insights.sbomify.com/CVE-2017-11767/): ChakraCore vulnerable to privilege escalation (critical 9.8)
- [CVE-2017-8658](https://insights.sbomify.com/CVE-2017-8658/): ChakraCore RCE Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-0993 and fix it if it is affected.

What it is: CVE-2019-0993 is a medium-severity memory corruption vulnerability in Microsoft Chakracore, published on 12 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-0993 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.ChakraCore (NuGet): affected all versions; fixed in 1.11.10
- Microsoft.ChakraCore (NuGet): affected all versions; fixed in 1.11.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-0993/ (Markdown: https://insights.sbomify.com/CVE-2019-0993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-0993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-0993
- OSV: https://osv.dev/vulnerability/CVE-2019-0993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-0993/
Summaries are generated and may contain mistakes; the official description above is the record.
