# CVE-2019-1000002: Gitea Arbitrary File Delete Vulnerability

> An attacker with write access to any repository can delete files outside their authorized scope due to incorrect access control checks.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j99q-rwp6-498g

## What is CVE-2019-1000002?

CVE-2019-1000002 is a medium-severity missing authorization vulnerability in Gitea Gitea, published on 4 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gitea version 1.6.2 and earlier contains a Incorrect Access Control vulnerability in Delete/Edit file functionallity that can result in the attacker deleting files outside the repository he/she has access to. This attack appears to be exploitable via the attacker must get write access to "any" repository including self-created ones.. This vulnerability appears to have been fixed in 1.6.3, 1.7.0-rc2.

## Which versions are affected by CVE-2019-1000002?

2 open source packages ship an affected version, including code.gitea.io/gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.6.3 |
| `code.gitea.io/gitea` | Go | All versions | 1.6.3 |

Products: Gitea Gitea.

## How do I fix CVE-2019-1000002?

Upgrade code.gitea.io/gitea to 1.6.3 or later.

## Is CVE-2019-1000002 being exploited?

There is no known exploitation of CVE-2019-1000002 in the wild and no public exploit code.

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1000002 and fix it if it is affected.

What it is: CVE-2019-1000002 is a medium-severity missing authorization vulnerability in Gitea Gitea, published on 4 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1000002 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.6.3
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1000002/ (Markdown: https://insights.sbomify.com/CVE-2019-1000002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1000002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1000002
- OSV: https://osv.dev/vulnerability/CVE-2019-1000002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1000002/
Summaries are generated and may contain mistakes; the official description above is the record.
