CVE-2019-1000003 Cross-site request forgery in n/a

High 8.8 Published Updated

An attacker can trick an admin into modifying post data and embedding JavaScript via CSRF in the MapSVG Lite plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2019-1000003?

CVE-2019-1000003 is a high-severity vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

MapSVG MapSVG Lite version 3.2.3 contains a Cross Site Request Forgery (CSRF) vulnerability in REST endpoint /wp-admin/admin-ajax.php?action=mapsvg_save that can result in an attacker can modify post data, including embedding javascript. This attack appears to be exploitable via the victim must be logged in to WordPress as an admin, and click a link. This vulnerability appears to have been fixed in 3.3.0 and later.

Weakness: CWE-352

Which versions are affected by CVE-2019-1000003?

It affects 1 product.

Products include Mapsvg Mapsvg Lite.

How do I fix CVE-2019-1000003?

No fix has been published for CVE-2019-1000003 yet. Limit exposure of the affected software until one is available.

Is CVE-2019-1000003 being exploited?

There is no known exploitation of CVE-2019-1000003 in the wild and no public exploit code.

Sources

Also known as GHSA-gjmp-h39c-wjrg.

Is CVE-2019-1000003 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free