{"answers":{"affected":"3 open source packages ship an affected version, including aioxmpp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1000007 in the wild and no public exploit code.","fix":"Upgrade aioxmpp to 0.10.3 or later.","what":"CVE-2019-1000007 is a high-severity denial of service vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1000007 and fix it if it is affected.\n\nWhat it is: CVE-2019-1000007 is a high-severity denial of service vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1000007 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aioxmpp (PyPI): affected all versions; fixed in 0.10.3\n- aioxmpp (PyPI): affected all versions; fixed in 0.10.3\n- aioxmpp (PyPI): affected all versions; fixed in 0.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1000007/ (Markdown: https://insights.sbomify.com/CVE-2019-1000007/index.md)","id":"CVE-2019-1000007","markdown":"https://insights.sbomify.com/CVE-2019-1000007/index.md","name":"CVE-2019-1000007","record":{"aliases":["DEBIAN-CVE-2019-1000007","GHSA-6m9g-jr8c-cqw3","PYSEC-2019-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python XMPP library","requires_auth":"none","summary":"A remote attacker can cause denial of service or data injection in applications using the aioxmpp library by sending a crafted stanza.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aioxmpp","vendor":"aioxmpp_project"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[],"description":"aioxmpp version 0.10.2 and earlier contains a Improper Handling of Structural Elements vulnerability in Stanza Parser, rollback during error processing, aioxmpp.xso.model.guard function that can result in Denial of Service, Other. This attack appears to be exploitable via Remote. A crafted stanza can be sent to an application which uses the vulnerable components to either inject data in a different context or cause the application to reconnect (potentially losing data). This vulnerability appears to have been fixed in 0.10.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Depth counting error in guard() leading to multiple potential security issues in aioxmpp","id":"CVE-2019-1000007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":3,"n_references":1,"next":{"headline":"Helm Path Traversal","id":"CVE-2019-1000008"},"packages":[{"ecosystem":"PyPI","fixed":["0.10.3"],"introduced":["0"],"last_affected":[],"package":"aioxmpp","purl":null,"source":"GHSA-6m9g-jr8c-cqw3"},{"ecosystem":"PyPI","fixed":["0.10.3"],"introduced":["0"],"last_affected":[],"package":"aioxmpp","purl":"pkg:pypi/aioxmpp","source":"GHSA-6m9g-jr8c-cqw3"},{"ecosystem":"PyPI","fixed":["0.10.3"],"introduced":["0"],"last_affected":[],"package":"aioxmpp","purl":"pkg:pypi/aioxmpp","source":"PYSEC-2019-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2019-1000006"},"products":["n/a"],"published":"2019-02-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A remote attacker can cause denial of service or data injection in applications using the aioxmpp library by sending a crafted stanza.","url":"https://insights.sbomify.com/CVE-2019-1000007/"}