# CVE-2019-1000007: Depth counting error in guard() leading to multiple potential security issues in aioxmpp

> A remote attacker can cause denial of service or data injection in applications using the aioxmpp library by sending a crafted stanza.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-1000007, GHSA-6m9g-jr8c-cqw3, PYSEC-2019-1

## What is CVE-2019-1000007?

CVE-2019-1000007 is a high-severity denial of service vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

aioxmpp version 0.10.2 and earlier contains a Improper Handling of Structural Elements vulnerability in Stanza Parser, rollback during error processing, aioxmpp.xso.model.guard function that can result in Denial of Service, Other. This attack appears to be exploitable via Remote. A crafted stanza can be sent to an application which uses the vulnerable components to either inject data in a different context or cause the application to reconnect (potentially losing data). This vulnerability appears to have been fixed in 0.10.3.

## Which versions are affected by CVE-2019-1000007?

3 open source packages ship an affected version, including aioxmpp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aioxmpp` | PyPI | All versions | 0.10.3 |
| `aioxmpp` | PyPI | All versions | 0.10.3 |
| `aioxmpp` | PyPI | All versions | 0.10.3 |

Products: Aioxmpp Project Aioxmpp.

## How do I fix CVE-2019-1000007?

Upgrade aioxmpp to 0.10.3 or later.

## Is CVE-2019-1000007 being exploited?

There is no known exploitation of CVE-2019-1000007 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1000007 and fix it if it is affected.

What it is: CVE-2019-1000007 is a high-severity denial of service vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1000007 in the wild and no public exploit code.

Affected packages and fixed versions:
- aioxmpp (PyPI): affected all versions; fixed in 0.10.3
- aioxmpp (PyPI): affected all versions; fixed in 0.10.3
- aioxmpp (PyPI): affected all versions; fixed in 0.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1000007/ (Markdown: https://insights.sbomify.com/CVE-2019-1000007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1000007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1000007
- OSV: https://osv.dev/vulnerability/CVE-2019-1000007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1000007/
Summaries are generated and may contain mistakes; the official description above is the record.
