# CVE-2019-1000008: Helm Path Traversal

> Attackers can write files outside the target directory by tricking users into processing a malicious Helm chart archive.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xrxm-mvqm-r553, GO-2023-1948

## What is CVE-2019-1000008?

CVE-2019-1000008 is a medium-severity path traversal vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands `helm fetch --untar` and `helm lint some.tgz` that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-1000008?

3 open source packages ship an affected version, including helm.sh/helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm` | Go | From 2.0.0 | 2.12.2 |
| `helm.sh/helm` | Go | From 2.0.0 | 2.12.2 |
| `helm.sh/helm` | Go | From 2.0.0+incompatible | 2.12.2+incompatible |

Products: Helm Helm.

## How do I fix CVE-2019-1000008?

Upgrade helm.sh/helm to a fixed version for your release line: 2.12.2 or 2.12.2+incompatible.

## Is CVE-2019-1000008 being exploited?

There is no known exploitation of CVE-2019-1000008 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1000008 and fix it if it is affected.

What it is: CVE-2019-1000008 is a medium-severity path traversal vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1000008 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm (Go): affected from 2.0.0; fixed in 2.12.2
- helm.sh/helm (Go): affected from 2.0.0; fixed in 2.12.2
- helm.sh/helm (Go): affected from 2.0.0+incompatible; fixed in 2.12.2+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1000008/ (Markdown: https://insights.sbomify.com/CVE-2019-1000008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1000008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1000008
- OSV: https://osv.dev/vulnerability/CVE-2019-1000008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1000008/
Summaries are generated and may contain mistakes; the official description above is the record.
