CVE-2019-1000010 Cross-site scripting in n/a

Medium 6.1 Published Updated

An attacker can execute arbitrary code in a victim's browser via a crafted link in phpIPAM, requiring user interaction.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2019-1000010?

CVE-2019-1000010 is a medium-severity cross-site scripting vulnerability in Phpipam Phpipam, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

phpIPAM version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in subnet-scan-telnet.php that can result in executing code in victims browser. This attack appears to be exploitable via victim visits link crafted by an attacker. This vulnerability appears to have been fixed in 1.4.

Weakness: CWE-79

Which versions are affected by CVE-2019-1000010?

It affects 1 product.

Products include Phpipam Phpipam.

How do I fix CVE-2019-1000010?

No fix has been published for CVE-2019-1000010 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-1000010 being exploited?

There is no known exploitation of CVE-2019-1000010 in the wild and no public exploit code.

All Phpipam Phpipam vulnerabilities

Sources

Also known as GHSA-598p-ff2g-5p9p.

Is CVE-2019-1000010 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free