{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1000010 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2019-1000010 yet. Limit exposure of the affected software until one is available.","what":"CVE-2019-1000010 is a medium-severity cross-site scripting vulnerability in Phpipam Phpipam, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1000010 and fix it if it is affected.\n\nWhat it is: CVE-2019-1000010 is a medium-severity cross-site scripting vulnerability in Phpipam Phpipam, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1000010 in the wild and no public exploit code.\n\nAffected product: Phpipam Phpipam. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1000010/ (Markdown: https://insights.sbomify.com/CVE-2019-1000010/index.md)","id":"CVE-2019-1000010","markdown":"https://insights.sbomify.com/CVE-2019-1000010/index.md","name":"CVE-2019-1000010","record":{"aliases":["GHSA-598p-ff2g-5p9p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"IPAM web application","requires_auth":"none","summary":"An attacker can execute arbitrary code in a victim's browser via a crafted link in phpIPAM, requiring user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpipam","vendor":"phpipam"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpIPAM version 1.3.2 and earlier contains a Cross Site Scripting (XSS) vulnerability in subnet-scan-telnet.php that can result in executing code in victims browser. This attack appears to be exploitable via victim visits link crafted by an attacker. This vulnerability appears to have been fixed in 1.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Cross-site scripting in n/a","id":"CVE-2019-1000010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"phpipam:phpipam","products":["phpipam:phpipam"],"type":"xss","year":"2019"},"n_packages":0,"n_references":2,"next":{"headline":"Incorrect Access Control vulnerability in api-platform/core","id":"CVE-2019-1000011"},"packages":[],"prev":{"headline":"Path traversal in n/a","id":"CVE-2019-1000009"},"products":["n/a"],"published":"2019-02-04","related":[{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2022-41443","kev_date_added":null,"published":"2022-10-03"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-16692","kev_date_added":null,"published":"2019-09-22"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-16693","kev_date_added":null,"published":"2019-09-22"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-16694","kev_date_added":null,"published":"2019-09-22"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-16695","kev_date_added":null,"published":"2019-09-22"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-16696","kev_date_added":null,"published":"2019-09-22"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2018-1000869","kev_date_added":null,"published":"2018-12-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code in a victim's browser via a crafted link in phpIPAM, requiring user interaction.","url":"https://insights.sbomify.com/CVE-2019-1000010/"}