# CVE-2019-1000013: Hex authenticity of signed packages not validated

> Attackers can modify packages undetected via malicious mirrors, leading to code execution when victims fetch packages.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-q3cc-rr2c-87r6

## What is CVE-2019-1000013?

CVE-2019-1000013 is a high-severity vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Hex package manager hex_core version 0.3.0 and earlier contains a Signing oracle vulnerability in Package registry verification that can result in Package modifications not detected, allowing code execution. This attack appears to be exploitable via victim fetches packages from malicious/compromised mirror. This vulnerability appears to have been fixed in 0.4.0.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2019-1000013?

2 open source packages ship an affected version, including hex_core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hex_core` | Hex | All versions | 0.4.0 |
| `hex_core` | Hex | All versions | 0.4.0 |

Products: Hex Hex Core.

## How do I fix CVE-2019-1000013?

Upgrade hex_core to 0.4.0 or later.

## Is CVE-2019-1000013 being exploited?

There is no known exploitation of CVE-2019-1000013 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1000013 and fix it if it is affected.

What it is: CVE-2019-1000013 is a high-severity vulnerability in n/a, published on 4 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1000013 in the wild and no public exploit code.

Affected packages and fixed versions:
- hex_core (Hex): affected all versions; fixed in 0.4.0
- hex_core (Hex): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1000013/ (Markdown: https://insights.sbomify.com/CVE-2019-1000013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1000013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1000013
- OSV: https://osv.dev/vulnerability/CVE-2019-1000013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1000013/
Summaries are generated and may contain mistakes; the official description above is the record.
