CVE-2019-1002100 Kubernetes DoS Vulnerability
Authorized users can cause a Denial of Service on the Kubernetes API Server by sending specially crafted json-patch requests that consume excessive resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-1002100?
CVE-2019-1002100 is a medium-severity denial of service vulnerability in Kubernetes Kubernetes, published on 1 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. `kubectl patch --type json` or `"Content-Type: application/json-patch+json"`) that consumes excessive resources while processing, causing a Denial of Service on the API Server.
Weakness: CWE-770
Which versions are affected by CVE-2019-1002100?
9 open source packages ship an affected version, including k8s.io/kubernetes. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
k8s.io/kubernetes Go | From 1.0.0 | 1.11.8, 1.12.6, 1.13.4 |
k8s.io/kubernetes Go | From 1.0.0 to 1.10.14 | None |
k8s.io/kubernetes Go | From 1.0.0 to 1.10.14 | None |
k8s.io/kubernetes Go | From 1.11.0 | 1.11.8 |
k8s.io/kubernetes Go | From 1.11.0 | 1.11.8 |
k8s.io/kubernetes Go | From 1.12.0 | 1.12.6 |
3 more packages
k8s.io/kubernetes Go | From 1.12.0 | 1.12.6 |
k8s.io/kubernetes Go | From 1.13.0 | 1.13.4 |
k8s.io/kubernetes Go | From 1.13.0 | 1.13.4 |
Products include Kubernetes Kubernetes, Redhat Openshift Container Platform.
How do I fix CVE-2019-1002100?
Upgrade k8s.io/kubernetes to a fixed version for your release line: 1.11.8, 1.12.6 or 1.13.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-1002100 being exploited?
There is no known exploitation of CVE-2019-1002100 in the wild and no public exploit code.
Other vulnerabilities in Kubernetes Kubernetes
- CVE-2018-1002105 Privilege Escalation in Kubernetes
- CVE-2017-1000056 Kubernetes Privilege Escalation
- CVE-2016-1906 Authorization bypass in Openshift
- CVE-2023-3676 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation
- CVE-2023-3955 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation
Sources
Also known as DEBIAN-CVE-2019-1002100, GHSA-q4rr-64r9-fwgf, GO-2023-1946.