# CVE-2019-1003000: Protection Mechanism Failure in Jenkins Script Security Plugin

> Attackers can bypass the Groovy sandbox to execute arbitrary code on the Jenkins master JVM via malicious scripts.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-784j-h234-m56x

## What is CVE-2019-1003000?

CVE-2019-1003000 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability exists in Script Security Plugin 1.49 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java that allows attackers with the ability to provide sandboxed scripts to execute arbitrary code on the Jenkins master JVM.

## Which versions are affected by CVE-2019-1003000?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.50 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.50 |

Products: Jenkins Script Security, Redhat Openshift Container Platform.

## How do I fix CVE-2019-1003000?

Upgrade org.jenkins-ci.plugins:script-security to 1.50 or later.

## Is CVE-2019-1003000 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003000 exists.

Public exploit code:

- Jenkins RCE Proof-of-Concept: SECURITY-1266 / CVE-2019-1003000 (Script Security), CVE-2019-1003001 (Pipeline: Groovy), CVE-2019-1003002 (Pipeline: Declarative) (github_poc): https://github.com/adamyordan/cve-2019-1003000-jenkins-rce-poc
- CVE-2020-8012, CVE-2016-10709, CVE-2017-17099, CVE-2017-18047, CVE-2019-1003000, CVE-2018-1999002 (github_poc): https://github.com/wetw0rk/Exploit-Development
- A C# module  to detect if a Jenkins server is vulnerable to the RCE vulnerability found in CVE-2019-1003000 (chained with  CVE-2018-1000861 for pre-auth RCE) (github_poc): https://github.com/1NTheKut/CVE-2019-1003000_RCE-DETECTION
- https://github.com/purple-WL/Jenkins_CVE-2019-1003000 (github_poc): https://github.com/purple-WL/Jenkins_CVE-2019-1003000
- Jenkins ACL Bypass and Metaprogramming RCE (metasploit)
- Jenkins Plugin Script Security < 1.50/Declarative < 1.3.4.1/Groovy < 2.61.1 - Remote Code Execution (PoC) (exploitdb)

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2019-1003029](https://insights.sbomify.com/CVE-2019-1003029/): Jenkins Script Security Plugin Sandbox Bypass (critical 9.9, exploited in the wild)
- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003000 and fix it if it is affected.

What it is: CVE-2019-1003000 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003000 exists.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.50
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003000/ (Markdown: https://insights.sbomify.com/CVE-2019-1003000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003000
- OSV: https://osv.dev/vulnerability/CVE-2019-1003000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003000/
Summaries are generated and may contain mistakes; the official description above is the record.
