# CVE-2019-1003001: Jenkins Groovy Plugin sandbox bypass vulnerability

> Attackers with read permissions can execute arbitrary code on the Jenkins master by submitting malicious pipeline scripts via an HTTP endpoint.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6q78-6xvr-26fg

## What is CVE-2019-1003001?

CVE-2019-1003001 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in src/main/java/org/jenkinsci/plugins/workflow/cps/CpsFlowDefinition.java, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShellFactory.java that allows attackers with Overall/Read permission to provide a pipeline script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

## Which versions are affected by CVE-2019-1003001?

6 open source packages ship an affected version, including org.jenkins-ci.plugins.workflow:workflow-cps-parent, org.jenkins-ci.plugins:pipeline-model-definition and org.jenkins-ci.plugins:script-security. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins.workflow:workflow-cps-parent` | Maven | All versions | 2.61.1 |
| `org.jenkins-ci.plugins.workflow:workflow-cps-parent` | Maven | All versions | 2.61.1 |
| `org.jenkins-ci.plugins:pipeline-model-definition` | Maven | All versions | 1.3.4.1 |
| `org.jenkins-ci.plugins:pipeline-model-definition` | Maven | All versions | 1.3.4.1 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.50 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.50 |

Products: Jenkins Pipeline\, Redhat Openshift Container Platform.

## How do I fix CVE-2019-1003001?

Upgrade org.jenkins-ci.plugins.workflow:workflow-cps-parent to 2.61.1 or later.

## Is CVE-2019-1003001 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003001 exists.

Public exploit code:

- Jenkins ACL Bypass and Metaprogramming RCE (metasploit)
- Jenkins Plugin Script Security < 1.50/Declarative < 1.3.4.1/Groovy < 2.61.1 - Remote Code Execution (PoC) (exploitdb)
- Jenkins 2.137 and Pipeline Groovy Plugin 2.61 - ACL Bypass and Metaprogramming Remote Code Execution (Metasploit) (exploitdb)
- Jenkins 2.137 and Pipeline Groovy Plugin 2.61 - ACL Bypass and Metaprogramming Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2019-1003030](https://insights.sbomify.com/CVE-2019-1003030/): Jenkins Matrix Project Plugin Remote Code Execution (critical 9.9, exploited in the wild)
- [CVE-2022-43402](https://insights.sbomify.com/CVE-2022-43402/): Jenkins Pipeline: Groovy Plugin allows sandbox protection bypass and arbitrary code execution (critical 9.9)
- [CVE-2019-1003041](https://insights.sbomify.com/CVE-2019-1003041/): Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin (critical 9.8)
- [CVE-2022-43407](https://insights.sbomify.com/CVE-2022-43407/): CSRF protection for any URL can be bypassed in Jenkins Pipeline: Input Step Plugin (high 8.8)
- [CVE-2022-25173](https://insights.sbomify.com/CVE-2022-25173/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Pipeline: Groovy Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003001 and fix it if it is affected.

What it is: CVE-2019-1003001 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003001 exists.

Affected packages and fixed versions:
- org.jenkins-ci.plugins.workflow:workflow-cps-parent (Maven): affected all versions; fixed in 2.61.1
- org.jenkins-ci.plugins.workflow:workflow-cps-parent (Maven): affected all versions; fixed in 2.61.1
- org.jenkins-ci.plugins:pipeline-model-definition (Maven): affected all versions; fixed in 1.3.4.1
- org.jenkins-ci.plugins:pipeline-model-definition (Maven): affected all versions; fixed in 1.3.4.1
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.50
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003001/ (Markdown: https://insights.sbomify.com/CVE-2019-1003001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003001
- OSV: https://osv.dev/vulnerability/CVE-2019-1003001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003001/
Summaries are generated and may contain mistakes; the official description above is the record.
