# CVE-2019-1003002: Jenkins Pipeline Declarative Plugin sandbox bypass vulnerability

> Attackers with read permissions can execute arbitrary code on the Jenkins master via a sandbox bypass in the Pipeline Declarative plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-x6jx-cxg3-mggh

## What is CVE-2019-1003002?

CVE-2019-1003002 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier in pipeline-model-definition/src/main/groovy/org/jenkinsci/plugins/pipeline/modeldefinition/parser/Converter.groovy that allows attackers with Overall/Read permission to provide a pipeline script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

## Which versions are affected by CVE-2019-1003002?

2 open source packages ship an affected version, including org.jenkinsci.plugins:pipeline-model-definition. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkinsci.plugins:pipeline-model-definition` | Maven | All versions | 1.3.4.1 |
| `org.jenkinsci.plugins:pipeline-model-definition` | Maven | All versions | 1.3.4.1 |

Products: Jenkins Pipeline\, Redhat Openshift Container Platform.

## How do I fix CVE-2019-1003002?

Upgrade org.jenkinsci.plugins:pipeline-model-definition to 1.3.4.1 or later.

## Is CVE-2019-1003002 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003002 exists.

Public exploit code:

- Jenkins ACL Bypass and Metaprogramming RCE (metasploit)
- Jenkins Plugin Script Security < 1.50/Declarative < 1.3.4.1/Groovy < 2.61.1 - Remote Code Execution (PoC) (exploitdb)
- Jenkins 2.137 and Pipeline Groovy Plugin 2.61 - ACL Bypass and Metaprogramming Remote Code Execution (Metasploit) (exploitdb)
- Jenkins 2.137 and Pipeline Groovy Plugin 2.61 - ACL Bypass and Metaprogramming Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2019-1003030](https://insights.sbomify.com/CVE-2019-1003030/): Jenkins Matrix Project Plugin Remote Code Execution (critical 9.9, exploited in the wild)
- [CVE-2022-43402](https://insights.sbomify.com/CVE-2022-43402/): Jenkins Pipeline: Groovy Plugin allows sandbox protection bypass and arbitrary code execution (critical 9.9)
- [CVE-2019-1003041](https://insights.sbomify.com/CVE-2019-1003041/): Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin (critical 9.8)
- [CVE-2022-43407](https://insights.sbomify.com/CVE-2022-43407/): CSRF protection for any URL can be bypassed in Jenkins Pipeline: Input Step Plugin (high 8.8)
- [CVE-2022-25173](https://insights.sbomify.com/CVE-2022-25173/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Pipeline: Groovy Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003002 and fix it if it is affected.

What it is: CVE-2019-1003002 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 22 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003002 exists.

Affected packages and fixed versions:
- org.jenkinsci.plugins:pipeline-model-definition (Maven): affected all versions; fixed in 1.3.4.1
- org.jenkinsci.plugins:pipeline-model-definition (Maven): affected all versions; fixed in 1.3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003002/ (Markdown: https://insights.sbomify.com/CVE-2019-1003002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003002
- OSV: https://osv.dev/vulnerability/CVE-2019-1003002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003002/
Summaries are generated and may contain mistakes; the official description above is the record.
