CVE-2019-1003003 Improper Authorization in Jenkins Core

High 7.2 Published Updated

Attackers with RunScripts permission can create non-expiring Remember Me cookies to persist access to compromised accounts in Jenkins.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-1003003?

CVE-2019-1003003 is a high-severity vulnerability in Jenkins Jenkins, published on 22 Jan 2019. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An improper authorization vulnerability exists in Jenkins 2.158 and earlier, LTS 2.150.1 and earlier in core/src/main/java/hudson/security/TokenBasedRememberMeServices2.java that allows attackers with Overall/RunScripts permission to craft Remember Me cookies that would never expire, allowing e.g. to persist access to temporarily compromised user accounts.

Which versions are affected by CVE-2019-1003003?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.150.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.150.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.1512.159
org.jenkins-ci.main:jenkins-core MavenFrom 2.1512.159

Products include Jenkins Jenkins, Redhat Openshift Container Platform.

How do I fix CVE-2019-1003003?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.150.2 or 2.159.

Is CVE-2019-1003003 being exploited?

There is no known exploitation of CVE-2019-1003003 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-6rh5-23hx-j452.

Is CVE-2019-1003003 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free