# CVE-2019-1003003: Improper Authorization in Jenkins Core

> Attackers with RunScripts permission can create non-expiring Remember Me cookies to persist access to compromised accounts in Jenkins.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6rh5-23hx-j452

## What is CVE-2019-1003003?

CVE-2019-1003003 is a high-severity vulnerability in Jenkins Jenkins, published on 22 Jan 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An improper authorization vulnerability exists in Jenkins 2.158 and earlier, LTS 2.150.1 and earlier in core/src/main/java/hudson/security/TokenBasedRememberMeServices2.java that allows attackers with Overall/RunScripts permission to craft Remember Me cookies that would never expire, allowing e.g. to persist access to temporarily compromised user accounts.

## Which versions are affected by CVE-2019-1003003?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.150.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.150.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.151 | 2.159 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.151 | 2.159 |

Products: Jenkins Jenkins, Redhat Openshift Container Platform.

## How do I fix CVE-2019-1003003?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.150.2 or 2.159.

## Is CVE-2019-1003003 being exploited?

There is no known exploitation of CVE-2019-1003003 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003003 and fix it if it is affected.

What it is: CVE-2019-1003003 is a high-severity vulnerability in Jenkins Jenkins, published on 22 Jan 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003003 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.150.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.150.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.151; fixed in 2.159
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.151; fixed in 2.159

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003003/ (Markdown: https://insights.sbomify.com/CVE-2019-1003003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003003
- OSV: https://osv.dev/vulnerability/CVE-2019-1003003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003003/
Summaries are generated and may contain mistakes; the official description above is the record.
