{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003005 exists.","fix":"Upgrade org.jenkins-ci.plugins:script-security to 1.51 or later.","what":"CVE-2019-1003005 is a high-severity code injection vulnerability in Jenkins Script Security Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1003005 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003005 is a high-severity code injection vulnerability in Jenkins Script Security Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-1003005 exists.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.51\n- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.51\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003005/ (Markdown: https://insights.sbomify.com/CVE-2019-1003005/index.md)","id":"CVE-2019-1003005","markdown":"https://insights.sbomify.com/CVE-2019-1003005/index.md","name":"CVE-2019-1003005","record":{"aliases":["GHSA-x5jm-rj37-5qh7"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Script Security Plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can execute arbitrary code on the Jenkins master via a sandbox bypass in the Script Security Plugin.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"script_security","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.50 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2019-01-08","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2019-01-08","kind":"metasploit","ref":"exploit/multi/http/jenkins_metaprogramming","stars":null,"title":"Jenkins ACL Bypass and Metaprogramming RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"Sandbox Bypass in Script Security Plugin","id":"CVE-2019-1003005","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Jenkins Groovy Plugin sandbox bypass vulnerability","id":"CVE-2019-1003006"},"packages":[{"ecosystem":"Maven","fixed":["1.51"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":null,"source":"GHSA-x5jm-rj37-5qh7"},{"ecosystem":"Maven","fixed":["1.51"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:script-security","purl":"pkg:maven/org.jenkins-ci.plugins/script-security","source":"GHSA-x5jm-rj37-5qh7"}],"prev":{"headline":"Improper Authorization in Jenkins Core","id":"CVE-2019-1003004"},"products":["Jenkins Script Security Plugin"],"published":"2019-02-06","related":[{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin Sandbox Bypass","id":"CVE-2019-1003029","kev_date_added":"2022-04-25","published":"2019-03-08"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43401","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Jenkins Script Security Plugin sandbox bypass vulnerability","id":"CVE-2022-43403","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin","id":"CVE-2022-43404","kev_date_added":null,"published":"2022-10-19"},{"cvss_score":9.9,"headline":"Sandbox bypass vulnerability in Jenkins Script Security Plugin","id":"CVE-2020-2279","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":9.9,"headline":"Improper Control of Generation of Code in Jenkins Script Security Plugin","id":"CVE-2019-10431","kev_date_added":null,"published":"2019-10-01"},{"cvss_score":9.8,"headline":"Jenkins Script Security Plugin has sandbox bypass vulnerability involving crafted constructor bodies","id":"CVE-2024-34144","kev_date_added":null,"published":"2024-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can execute arbitrary code on the Jenkins master via a sandbox bypass in the Script Security Plugin.","url":"https://insights.sbomify.com/CVE-2019-1003005/"}