{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:groovy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003006 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:groovy to 2.1 or later.","what":"CVE-2019-1003006 is a high-severity code injection vulnerability in Jenkins Groovy Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1003006 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003006 is a high-severity code injection vulnerability in Jenkins Groovy Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1003006 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:groovy (Maven): affected all versions; fixed in 2.1\n- org.jenkins-ci.plugins:groovy (Maven): affected all versions; fixed in 2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003006/ (Markdown: https://insights.sbomify.com/CVE-2019-1003006/index.md)","id":"CVE-2019-1003006","markdown":"https://insights.sbomify.com/CVE-2019-1003006/index.md","name":"CVE-2019-1003006","record":{"aliases":["GHSA-xfwj-2f34-32f5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Groovy Plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can execute arbitrary code on the Jenkins master via a Groovy script injection in the plugin.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"groovy","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"A sandbox bypass vulnerability exists in Jenkins Groovy Plugin 2.0 and earlier in src/main/java/hudson/plugins/groovy/StringScriptSource.java that allows attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Groovy Plugin sandbox bypass vulnerability","id":"CVE-2019-1003006","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Sandbox Bypass via CSRF in Jenkins Warnings Plugin","id":"CVE-2019-1003007"},"packages":[{"ecosystem":"Maven","fixed":["2.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:groovy","purl":null,"source":"GHSA-xfwj-2f34-32f5"},{"ecosystem":"Maven","fixed":["2.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:groovy","purl":"pkg:maven/org.jenkins-ci.plugins/groovy","source":"GHSA-xfwj-2f34-32f5"}],"prev":{"headline":"Sandbox Bypass in Script Security Plugin","id":"CVE-2019-1003005"},"products":["Jenkins Groovy Plugin"],"published":"2019-02-06","related":[{"cvss_score":8.8,"headline":"Jenkins Groovy Plugin sandbox bypass vulnerability","id":"CVE-2019-1003033","kev_date_added":null,"published":"2019-03-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can execute arbitrary code on the Jenkins master via a Groovy script injection in the plugin.","url":"https://insights.sbomify.com/CVE-2019-1003006/"}