{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:warnings. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003007 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:warnings to 5.0.1 or later.","what":"CVE-2019-1003007 is a high-severity vulnerability in Jenkins Warnings Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1003007 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003007 is a high-severity vulnerability in Jenkins Warnings Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1003007 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:warnings (Maven): affected all versions; fixed in 5.0.1\n- org.jvnet.hudson.plugins:warnings (Maven): affected all versions; fixed in 5.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003007/ (Markdown: https://insights.sbomify.com/CVE-2019-1003007/index.md)","id":"CVE-2019-1003007","markdown":"https://insights.sbomify.com/CVE-2019-1003007/index.md","name":"CVE-2019-1003007","record":{"aliases":["GHSA-mmrv-3cqg-hpf9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Warnings Plugin","requires_auth":"none","summary":"Attackers can execute arbitrary code via CSRF in the Jenkins Warnings Plugin form validation endpoint.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"warnings","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery vulnerability exists in Jenkins Warnings Plugin 5.0.0 and earlier in src/main/java/hudson/plugins/warnings/GroovyParser.java that allows attackers to execute arbitrary code via a form validation HTTP endpoint.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sandbox Bypass via CSRF in Jenkins Warnings Plugin","id":"CVE-2019-1003007","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability","id":"CVE-2019-1003008"},"packages":[{"ecosystem":"Maven","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:warnings","purl":null,"source":"GHSA-mmrv-3cqg-hpf9"},{"ecosystem":"Maven","fixed":["5.0.1"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:warnings","purl":"pkg:maven/org.jvnet.hudson.plugins/warnings","source":"GHSA-mmrv-3cqg-hpf9"}],"prev":{"headline":"Jenkins Groovy Plugin sandbox bypass vulnerability","id":"CVE-2019-1003006"},"products":["Jenkins Warnings Plugin"],"published":"2019-02-06","related":[{"cvss_score":8.8,"headline":"CSRF vulnerability in Jenkins warnings Plugin allows remote code execution","id":"CVE-2020-2280","kev_date_added":null,"published":"2020-09-23"},{"cvss_score":8.8,"headline":"XXE vulnerability Jenkins Warnings Plugin","id":"CVE-2018-1000012","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":6.5,"headline":"Jenkins Warnings Plugin exposures system-scoped credentials","id":"CVE-2023-46651","kev_date_added":null,"published":"2023-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Jenkins project"]},"summary":"Attackers can execute arbitrary code via CSRF in the Jenkins Warnings Plugin form validation endpoint.","url":"https://insights.sbomify.com/CVE-2019-1003007/"}