# CVE-2019-1003009: Jenkins Active Directory Plugin Improper certificate validation with StartTLS

> Attackers can impersonate the Active Directory server to bypass authentication if Jenkins uses StartTLS, potentially leading to account takeover.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-2h95-4xw9-m68j

## What is CVE-2019-1003009?

CVE-2019-1003009 is a high-severity vulnerability in Jenkins Active Directory Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An improper certificate validation vulnerability exists in Jenkins Active Directory Plugin 2.10 and earlier in src/main/java/hudson/plugins/active_directory/ActiveDirectoryDomain.java, src/main/java/hudson/plugins/active_directory/ActiveDirectorySecurityRealm.java, src/main/java/hudson/plugins/active_directory/ActiveDirectoryUnixAuthenticationProvider.java that allows attackers to impersonate the Active Directory server Jenkins connects to for authentication if Jenkins is configured to use StartTLS.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-1003009?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:active-directory. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:active-directory` | Maven | All versions | 2.11 |
| `org.jenkins-ci.plugins:active-directory` | Maven | All versions | 2.11 |

Products: Jenkins Active Directory.

## How do I fix CVE-2019-1003009?

Upgrade org.jenkins-ci.plugins:active-directory to 2.11 or later.

## Is CVE-2019-1003009 being exploited?

There is no known exploitation of CVE-2019-1003009 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Active Directory Plugin

- [CVE-2020-2299](https://insights.sbomify.com/CVE-2020-2299/): Improper Authentication in Jenkins Active Directory Plugin (critical 9.8)
- [CVE-2020-2300](https://insights.sbomify.com/CVE-2020-2300/): Improper Authentication (empty password) in Jenkins Active Directory Plugin (critical 9.8)
- [CVE-2020-2301](https://insights.sbomify.com/CVE-2020-2301/): Authentication cache in Active Directory Jenkins Plugin allows logging in with any password (critical 9.8)
- [CVE-2017-2649](https://insights.sbomify.com/CVE-2017-2649/): Jenkins Active Directory Plugin did not verify certificate of AD server (high 8.1)
- [CVE-2026-48918](https://insights.sbomify.com/CVE-2026-48918/): Jenkins Active Directory Plugin follows LDAP referrals by default (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003009 and fix it if it is affected.

What it is: CVE-2019-1003009 is a high-severity vulnerability in Jenkins Active Directory Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003009 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:active-directory (Maven): affected all versions; fixed in 2.11
- org.jenkins-ci.plugins:active-directory (Maven): affected all versions; fixed in 2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003009/ (Markdown: https://insights.sbomify.com/CVE-2019-1003009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003009
- OSV: https://osv.dev/vulnerability/CVE-2019-1003009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003009/
Summaries are generated and may contain mistakes; the official description above is the record.
