{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:config-file-provider. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-1003014 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:config-file-provider to 3.5 or later.","what":"CVE-2019-1003014 is a medium-severity cross-site scripting vulnerability in Redhat Openshift Container Platform, published on 6 Feb 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1003014 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003014 is a medium-severity cross-site scripting vulnerability in Redhat Openshift Container Platform, published on 6 Feb 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1003014 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 3.5\n- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003014/ (Markdown: https://insights.sbomify.com/CVE-2019-1003014/index.md)","id":"CVE-2019-1003014","markdown":"https://insights.sbomify.com/CVE-2019-1003014/index.md","name":"CVE-2019-1003014","record":{"aliases":["GHSA-pmc5-74w3-78mw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Config File Plugin","requires_auth":"high_privilege","summary":"Attackers with configuration permissions can execute arbitrary JavaScript in victims' browsers when deleting shared configuration files.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"config_file_provider","vendor":"jenkins"},{"product":"openshift_container_platform","vendor":"redhat"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An cross-site scripting vulnerability exists in Jenkins Config File Provider Plugin 3.4.1 and earlier in src/main/resources/lib/configfiles/configfiles.jelly that allows attackers with permission to define shared configuration files to execute arbitrary JavaScript when a user attempts to delete the shared configuration file.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Config File Provider Plugin XSS vulnerability","id":"CVE-2019-1003014","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"redhat:openshift_container_platform","products":["redhat:openshift_container_platform"],"type":"xss","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"XXE vulnerability in Jenkins Job Import Plugin","id":"CVE-2019-1003015"},"packages":[{"ecosystem":"Maven","fixed":["3.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:config-file-provider","purl":null,"source":"GHSA-pmc5-74w3-78mw"},{"ecosystem":"Maven","fixed":["3.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:config-file-provider","purl":"pkg:maven/org.jenkins-ci.plugins/config-file-provider","source":"GHSA-pmc5-74w3-78mw"}],"prev":{"headline":"Cross-site Scripting in Jenkins Blue Ocean Plugin","id":"CVE-2019-1003013"},"products":["Jenkins Config File Provider Plugin"],"published":"2019-02-06","related":[{"cvss_score":8.1,"headline":"XML External Entity Reference vulnerability in Jenkins Config File Provider Plugin","id":"CVE-2021-21642","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":8.1,"headline":"CSRF vulnerability in Config File Provider Plugin","id":"CVE-2018-1000414","kev_date_added":null,"published":"2019-01-09"},{"cvss_score":7.5,"headline":"Jenkins Config File Provider Plugin improper credential masking vulnerability","id":"CVE-2023-40339","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":6.5,"headline":"Incorrect permission checks in Jenkins Config File Provider Plugin allow enumerating credentials IDs","id":"CVE-2021-21643","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":6.5,"headline":"Improper Privilege Management in Jenkins Config File Provider Plugin","id":"CVE-2017-1000104","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":5.4,"headline":"CSRF vulnerability in Jenkins Config File Provider Plugin allows deleting configuration files","id":"CVE-2021-21644","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Config File Provider Plugin","id":"CVE-2018-1000413","kev_date_added":null,"published":"2019-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Attackers with configuration permissions can execute arbitrary JavaScript in victims' browsers when deleting shared configuration files.","url":"https://insights.sbomify.com/CVE-2019-1003014/"}