# CVE-2019-1003014: Jenkins Config File Provider Plugin XSS vulnerability

> Attackers with configuration permissions can execute arbitrary JavaScript in victims' browsers when deleting shared configuration files.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pmc5-74w3-78mw

## What is CVE-2019-1003014?

CVE-2019-1003014 is a medium-severity cross-site scripting vulnerability in Redhat Openshift Container Platform, published on 6 Feb 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

An cross-site scripting vulnerability exists in Jenkins Config File Provider Plugin 3.4.1 and earlier in src/main/resources/lib/configfiles/configfiles.jelly that allows attackers with permission to define shared configuration files to execute arbitrary JavaScript when a user attempts to delete the shared configuration file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-1003014?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:config-file-provider. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:config-file-provider` | Maven | All versions | 3.5 |
| `org.jenkins-ci.plugins:config-file-provider` | Maven | All versions | 3.5 |

Products: Jenkins Config File Provider, Redhat Openshift Container Platform.

## How do I fix CVE-2019-1003014?

Upgrade org.jenkins-ci.plugins:config-file-provider to 3.5 or later.

## Is CVE-2019-1003014 being exploited?

There is no known exploitation of CVE-2019-1003014 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2021-21642](https://insights.sbomify.com/CVE-2021-21642/): XML External Entity Reference vulnerability in Jenkins Config File Provider Plugin (high 8.1)
- [CVE-2018-1000414](https://insights.sbomify.com/CVE-2018-1000414/): CSRF vulnerability in Config File Provider Plugin (high 8.1)
- [CVE-2023-40339](https://insights.sbomify.com/CVE-2023-40339/): Jenkins Config File Provider Plugin improper credential masking vulnerability (high 7.5)
- [CVE-2021-21643](https://insights.sbomify.com/CVE-2021-21643/): Incorrect permission checks in Jenkins Config File Provider Plugin allow enumerating credentials IDs (medium 6.5)
- [CVE-2017-1000104](https://insights.sbomify.com/CVE-2017-1000104/): Improper Privilege Management in Jenkins Config File Provider Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003014 and fix it if it is affected.

What it is: CVE-2019-1003014 is a medium-severity cross-site scripting vulnerability in Redhat Openshift Container Platform, published on 6 Feb 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1003014 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 3.5
- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003014/ (Markdown: https://insights.sbomify.com/CVE-2019-1003014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003014
- OSV: https://osv.dev/vulnerability/CVE-2019-1003014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003014/
Summaries are generated and may contain mistakes; the official description above is the record.
